Most important changes: o added user-land programs: kalog, aklog, arla-cli o improved user-land programs: vos, bos, pts, etc. o added man pages o security fix (in rx) o and tons of bug fixes I included a start script to be placed under /etc/rc.d.
26 lines
881 B
Text
26 lines
881 B
Text
$NetBSD: patch-at,v 1.2 2001/08/09 13:49:00 wennmach Exp $
|
|
|
|
Set up proper path to the LKM for startarla.
|
|
|
|
--- xfs/bsd/bin/Makefile.in.orig Mon Jul 16 07:37:45 2001
|
|
+++ xfs/bsd/bin/Makefile.in Fri Aug 3 14:53:46 2001
|
|
@@ -20,6 +20,7 @@
|
|
libdir = @libdir@
|
|
libexecdir = @libexecdir@
|
|
bindir = @bindir@
|
|
+lkmdir = @prefix@/lkm
|
|
sbindir = @sbindir@
|
|
mandir = @mandir@
|
|
transform = @program_transform_name@
|
|
@@ -58,7 +59,10 @@
|
|
$(RM) -f $(PROGRAMS) startarla *.o *~
|
|
|
|
startarla: startarla.in
|
|
- sed -e 's!%lkmdir%!$(bindir)!;s!%sbindir%!$(sbindir)!;s!%libexecdir%!$(libexecdir)!;s!%ARLACACHEDIR%!$(ARLACACHEDIR)!' $(srcdir)/startarla.in > $@.new
|
|
+ sed -e 's!%lkmdir%!$(lkmdir)!' \
|
|
+ -e 's!%sbindir%!$(sbindir)!' \
|
|
+ -e 's!%libexecdir%!$(libexecdir)!' \
|
|
+ -e 's!%ARLACACHEDIR%!$(ARLACACHEDIR)!' $(srcdir)/startarla.in > $@.new
|
|
mv $@.new $@
|
|
chmod +x $@
|
|
|