7fb711f0eb
can be used to create shared libraries _and_ be linked into a statically linked program. Instead of trying to hack libtool to do this, just accept the fact and do what you want another way! Remove the ugly hack in sasldb/Makefile.am that regenerated the static archive from the non-PIC object files. While this was fine for linking into programs, it breaks things when you link this into the sasldb plugin. Leaving it the other way, where the static archive from the PIC object files, is also unacceptable because there are potential problems on some platforms when linking an archive of of PIC objects into an executable. The solution: let the static archive contain PIC objects and be used to link into the sasldb plugin, but for the programs in the utils directory, explicitly add the non-PIC object files listed in $(SASL_DB_BACKEND_STATIC) to the files used to generate the programs. This is easy because SASL_DB_BACKEND_STATIC is already generated properly by config/sasldb.m4, so make use if it. This should fix problems with using Cyrus SASL on non-i386 platforms noted in PR pkg/26492 by Matt Dainty. Bump the PKGREVISION.
39 lines
1.6 KiB
Text
39 lines
1.6 KiB
Text
$NetBSD: patch-as,v 1.4 2004/08/06 06:36:18 jlam Exp $
|
|
|
|
--- utils/Makefile.in.orig Fri Jul 2 15:40:14 2004
|
|
+++ utils/Makefile.in
|
|
@@ -237,11 +237,11 @@ noinst_PROGRAMS = dbconverter-2
|
|
|
|
@NO_SASL_DB_MANS_TRUE@man_MANS =
|
|
|
|
-saslpasswd2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
|
|
+saslpasswd2_LDADD = $(SASL_DB_BACKEND_STATIC) $(all_sasl_libs)
|
|
saslpasswd2_SOURCES = saslpasswd.c
|
|
-sasldblistusers2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
|
|
+sasldblistusers2_LDADD = $(SASL_DB_BACKEND_STATIC) $(all_sasl_libs)
|
|
sasldblistusers2_SOURCES = sasldblistusers.c
|
|
-dbconverter_2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
|
|
+dbconverter_2_LDADD = $(SASL_DB_BACKEND_STATIC) $(all_sasl_libs)
|
|
|
|
testsuite_LDADD = $(all_sasl_libs) @DMALLOC_LIBS@
|
|
|
|
@@ -287,16 +287,16 @@ PROGRAMS = $(noinst_PROGRAMS) $(sbin_PRO
|
|
|
|
dbconverter_2_SOURCES = dbconverter-2.c
|
|
dbconverter_2_OBJECTS = dbconverter-2.$(OBJEXT)
|
|
-dbconverter_2_DEPENDENCIES = ../sasldb/libsasldb.la ../lib/libsasl2.la
|
|
+dbconverter_2_DEPENDENCIES = $(SASL_DB_BACKEND_STATIC) ../lib/libsasl2.la
|
|
dbconverter_2_LDFLAGS =
|
|
am_sasldblistusers2_OBJECTS = sasldblistusers.$(OBJEXT)
|
|
sasldblistusers2_OBJECTS = $(am_sasldblistusers2_OBJECTS)
|
|
-sasldblistusers2_DEPENDENCIES = ../sasldb/libsasldb.la \
|
|
+sasldblistusers2_DEPENDENCIES = $(SASL_DB_BACKEND_STATIC) \
|
|
../lib/libsasl2.la
|
|
sasldblistusers2_LDFLAGS =
|
|
am_saslpasswd2_OBJECTS = saslpasswd.$(OBJEXT)
|
|
saslpasswd2_OBJECTS = $(am_saslpasswd2_OBJECTS)
|
|
-saslpasswd2_DEPENDENCIES = ../sasldb/libsasldb.la ../lib/libsasl2.la
|
|
+saslpasswd2_DEPENDENCIES = $(SASL_DB_BACKEND_STATIC) ../lib/libsasl2.la
|
|
saslpasswd2_LDFLAGS =
|
|
am_smtptest_OBJECTS =
|
|
smtptest_OBJECTS = $(am_smtptest_OBJECTS)
|