on other libraries, on both ELF and (NetBSD/)a.out, to make libwwwssl.so.?.? depend on the correct openssl shared libraries, as determined by the setting of ${SSLBASE} in bsd.pkg.mk. This closes PR pkg/12570, and has the additional advantage that programs that _do_ _not_ need to link in "-lwwwssl" won't get "-lssl" or "-lcrypto" at all. Also, make"w3c" and "www" build again with USE_SOCKS=4.
13 lines
802 B
Text
13 lines
802 B
Text
$NetBSD: patch-ai,v 1.1 2001/04/20 12:33:54 fredb Exp $
|
|
|
|
--- libwww-config.in.orig Wed Jun 23 13:05:01 1999
|
|
+++ libwww-config.in
|
|
@@ -48,7 +48,7 @@
|
|
echo -I@includedir@ -I@includedir@/@PACKAGE@ @DEFS@
|
|
;;
|
|
--libs)
|
|
- echo -L@libdir@ @LWWWXML@ @LWWWZIP@ @LWWWWAIS@ @LWWWSQL@ -lwwwinit -lwwwapp -lwwwhtml -lwwwtelnet -lwwwnews -lwwwhttp -lwwwmime -lwwwgopher -lwwwftp -lwwwfile -lwwwdir -lwwwcache -lwwwstream -lwwwmux -lwwwtrans -lwwwcore -lwwwutils @LWWWMD5@ @LIBS@
|
|
+ echo -L@libdir@ -Wl,-R@libdir@ @LWWWXML@ @LWWWZIP@ @LWWWWAIS@ @LWWWSQL@ -lwwwinit -lwwwapp -lwwwhtml -lwwwtelnet -lwwwnews -lwwwhttp -lwwwmime -lwwwgopher -lwwwftp -lwwwfile -lwwwdir -lwwwcache -lwwwstream -lwwwmux -lwwwtrans -lwwwcore -lwwwutils @LWWWMD5@ @LIBS@
|
|
;;
|
|
*)
|
|
echo "${usage}" 1>&2
|