2e85bc7502
* rfc2045mkboundary.c was broken in 0.68 Changes 0.68: * rfc2045/rfc2045mkboundary.c (rfc2045_mk_boundary): truncate the hostname portion of the boundary to 30 chars. * courier/doc/courier.sgml: Remove descriptions of some configuration files that were moved to the courier-authlib package a while ago. They don't belong here any more. * courier/submit.C: Use the authenticated address, instead of the return address, for domain-based virtual configuration. * courier/libs/cfilename.c (config_has_vhost): Checks whether vhost.[ip] exists. * courier/module.esmtp/courieresmtpd.c (main): Only set a message's virtual host if vhost.[ip] exists. * courier/module.esmtp/esmtpclient.c (get_sourceaddr): Make sure the input buffer is null-terminated. * courier/submit.C (getrcpts): If there's no vhost setting from the sender's IP address (this includes local mail!) if vhost.domain exists, use [domain] as the virtual host. * Remove config_search(), which simply called config_localfilename(). Change all current callers to call config_localfilename(). * courier/libs/cfilename.c (config_set_local_vhost): saves a string that gets appended as a suffix, by config_localfilename(), and if that filename exists, that's returned as the filename, otherwise it's the original string without the suffix. config_get_local_vhost() returns the suffix string. to config_set_local_vhost(). * courier/libs/comsubmitclient.c (submit_fork): If config_get_local_vhost(), add a -vhost parameter to submit(). * courier/submit.C (cppmain): -vhost sets config_set_local_vhost(). * courier/submit2.C (closectl): New COMCTLFILE_VHOST parameter in the config file, taken from the vhost setting. * courier/libs/comctlfile.c (ctlfile_setvhost): If COMCTLFILE_VHOST is set, call ctlfile_setvhost(), return an indication if the vhost has changed. Absence of a COMCTLFILE_VHOST treated as a discrete "(null)" setting. * courier/module.esmtp/esmtpclient.c (esmtpchild): If ctlfile_setvhost() then disconnect the current socket, if one is open. * courier/module.esmtp/esmtpclient.c (get_sourceaddr): The IP address specified in ipout or ip6out overrides SOURCE_ADDRESS and SOURCE_ADDRESS_IPV6 environment variable. * courier/module.local/localmail.c (main): Call ctlfile_setvhost(). * courier/module.uucp/uucp.c (uux): Call ctlfile_setvhost(). * courier/module.dsn/dsn.c (main): Call ctlfile_setvhost(). * liblock/mail.c (dotlock_exists): Quell a compiler warning. * courier/courierd.dist.in SOURCE_ADDRESS: Add a note that this setting is deprecated.
110 lines
3.2 KiB
Text
110 lines
3.2 KiB
Text
$NetBSD: patch-ac,v 1.7 2012/06/09 11:45:38 adam Exp $
|
|
|
|
--- courier/doc/Makefile.in.orig 2007-11-17 19:48:53.000000000 -0500
|
|
+++ courier/doc/Makefile.in
|
|
@@ -169,7 +169,7 @@ top_srcdir = @top_srcdir@
|
|
version = @version@
|
|
htmldocdir = @datadir@/htmldoc
|
|
CLEANFILES = permissions.dat
|
|
-miscfiles = japanese_flag.png chinese_flag.png bg.gif icon.gif manpage.css \
|
|
+miscfiles = japanese_flag.png chinese_flag.png bg.gif icon.gif \
|
|
draft-varshavchik-exdata-smtpext.txt \
|
|
draft-varshavchik-verp-smtpext.txt \
|
|
draft-varshavchik-security-smtpext.txt \
|
|
@@ -207,67 +189,38 @@ htmlin = \
|
|
courier.html \
|
|
courierldapaliasd.html \
|
|
couriermlm.html \
|
|
- courierpop3d.html \
|
|
- couriertcpd.html \
|
|
- couriertls.html \
|
|
- deliverquota.html \
|
|
dot-courier.html \
|
|
dot-forward.html \
|
|
esmtpd.html \
|
|
- imapd.html \
|
|
localmailfilter.html \
|
|
- lockmail.html \
|
|
- mailbot.html \
|
|
- maildiracl.html \
|
|
- maildir.html \
|
|
- maildirkw.html \
|
|
- maildirmake.html \
|
|
- maildirquota.html \
|
|
- maildropex.html \
|
|
- maildropfilter.html \
|
|
- maildropgdbm.html \
|
|
- maildrop.html \
|
|
- maildrop.README.html \
|
|
- maildroptips.html \
|
|
mailq.html \
|
|
makeacceptmailfor.html \
|
|
makealiases.html \
|
|
- makedat.html \
|
|
makehosteddomains.html \
|
|
- makemime.html \
|
|
makepercentrelay.html \
|
|
makesmtpaccess.html \
|
|
- mimegpg.html \
|
|
mkesmtpdcert.html \
|
|
- mkimapdcert.html \
|
|
- mkpop3dcert.html \
|
|
- pcp_README.html \
|
|
pop3d.html \
|
|
preline.html \
|
|
- reformail.html \
|
|
- reformime.html \
|
|
sendmail.html \
|
|
submit.html \
|
|
testmxlookup.html \
|
|
webmlmd.html
|
|
|
|
htmldoc_DATA = $(nohtmlin) $(htmlin)
|
|
-man1 = sendmail.1 preline.1 maildirmake.1 cancelmsg.1 lockmail.1 maildrop.1 \
|
|
- mailq.1 mailbot.1 makemime.1 mimegpg.1 maildiracl.1 \
|
|
- makedat.1 reformail.1 reformime.1 couriermlm.1 testmxlookup.1 \
|
|
- dot-forward.1 couriertls.1 couriertcpd.1 maildirkw.1 \
|
|
- webmlmd.1
|
|
-
|
|
-man5 = dot-courier.5 maildir.5
|
|
-man7 = localmailfilter.7 maildirquota.7 maildropgdbm.7 maildropfilter.7 \
|
|
- maildropex.7
|
|
+man1 = sendmail.1 preline.1 cancelmsg.1 \
|
|
+ mailq.1 \
|
|
+ couriermlm.1 testmxlookup.1 \
|
|
+ dot-forward.1 webmlmd.1
|
|
|
|
-man8 = aliaslookup.8 courier.8 courierldapaliasd.8 courierpop3d.8 \
|
|
- deliverquota.8 \
|
|
+man5 = dot-courier.5
|
|
+man7 = localmailfilter.7
|
|
+
|
|
+man8 = aliaslookup.8 courier.8 courierldapaliasd.8 \
|
|
esmtpd.8 makeacceptmailfor.8 makehosteddomains.8\
|
|
- mkesmtpdcert.8 mkimapdcert.8 mkpop3dcert.8 \
|
|
+ mkesmtpdcert.8 \
|
|
makealiases.8 makepercentrelay.8 makesmtpaccess.8 \
|
|
- pop3d.8 pop3d-ssl.8 submit.8 imapd.8
|
|
+ submit.8
|
|
|
|
BUILT_SOURCES = \
|
|
aliaslookup.html aliaslookup.8 \
|
|
@@ -294,7 +265,7 @@ BUILT_SOURCES = \
|
|
webmlmd.html.in webmlmd.1.in
|
|
|
|
EXTRA_DIST = $(nohtmlin) $(BUILT_SOURCES) dotforward.1 pop3d-ssl.8
|
|
-man_LINKS = $(man8dir)/courierpop3login.8 \
|
|
+man_LINKS = \
|
|
$(man1dir)/rmail.1 $(man1dir)/dotforward.1 \
|
|
$(man8dir)/makesmtpaccess-msa.8 \
|
|
$(man8dir)/esmtpd-msa.8
|
|
@@ -1216,8 +1187,7 @@ preline.1: preline.1.in
|
|
|
|
install-man-extra:
|
|
cd $(DESTDIR)$(man8dir) ; \
|
|
- rm -f courierpop3login.8 makesmtpaccess-msa.8 esmtpd-msa.8; \
|
|
- $(LN_S) courierpop3d.8 courierpop3login.8; \
|
|
+ rm -f makesmtpaccess-msa.8 esmtpd-msa.8; \
|
|
$(LN_S) makesmtpaccess.8 makesmtpaccess-msa.8 ; \
|
|
$(LN_S) esmtpd.8 esmtpd-msa.8
|
|
cd $(DESTDIR)$(man1dir) ; rm -f rmail.1 dotforward.1 \
|