1f71c14556
2008-04-07 Mark Lindner <markl@neuromancer> * libconfig.spec - updated for 1.3 2008-04-03 Mark Lindner <markl@neuromancer> * scanner.l, grammar.y, libconfig.c, libconfig.h, wincompat.h - fix/add comment headers, add C90 portability fixes from Chris Pickett (C-style comments, renamed 'index' to 'idx' to resolve name clash) * scanner.c, grammar.c - regenerated * configure.ac - enable more gcc warnings * libconfigcpp.c++, libconfig.h++ - added getPath(), fixed impl of isRoot(), add portability fixes from Chris Pickett (renamed 'index' to 'idx' to resolve name clash), moved exception constructors into source file; changed SettingExistsException to SettingNameException to be more broad in scope * Makefile.am - add wincompat.h to sources; add missing debian files to EXTRA_DIST * test.cfg - added example 64-bit integer settings * samples/* - expanded some examples * doc/libconfig.texi - documentation updates * Makefile.am, *msvc7* - added (generated) VS2003 projects/solution 2008-03-22 Mark Lindner <markl@neuromancer> * debian/* - updates from Klaus Schneider 2008-03-22 Mark Lindner <markl@neuromancer> * scanner.l, grammar.y, libconfig.h++, libconfig.c, libconfig.h, wincompat.h, libconfigcpp.c++, grammar.c, scanner.c, grammar.h - add support for 64-bit integer values * libconfig.texi - documentation updates * Makefile.am, ac_config.h, configure.ac, libtool - bump version * libconfig.h - add config_setting_parent(), config_setting_is_root() * libconfigcpp.c++, libconfig.h++ - add isRoot(), getParent() to Setting 2008-03-15 Mark Lindner <markl@neuromancer> * scanner.l - made 'true' and 'false' tokens completely case-insensitive * libconfigcpp.cc, libconfig.hh - added alias files for Windows * libconfig.c, libconfig.h - modified __config_write_value() to write out floating point values in a more human-readable form; added name validation; added config_setting_remove_elem() and config_setting_index() * libconfigcpp.c++, libconfig.h++ - added remove(unsigned int) and getIndex() to Setting * libconfig.texi - documentation updates 2007-12-21 Mark Lindner <markl@neuromancer> * libconfig.c - source cleanup * config.guess, config.sub, ltmain.sh, libtool - updated to newer * configure.ac, Makefile.am, ac_config.h.in, ac_config.h - MinGW-related fixes
10 lines
273 B
Text
10 lines
273 B
Text
$NetBSD: patch-aa,v 1.1 2008/04/17 21:19:22 wiz Exp $
|
|
|
|
--- debian/libconfigduo2.postinst.orig 2008-03-22 21:16:39.000000000 +0000
|
|
+++ debian/libconfigduo2.postinst
|
|
@@ -1,4 +1,4 @@
|
|
#!/bin/sh
|
|
-if [ "$1" == "configure" ]; then
|
|
+if [ "$1" = "configure" ]; then
|
|
ldconfig
|
|
fi
|