pkgsrc/devel/opal-devel/patches/patch-plugins_video_H_263-1998_Makefile_in
jmcneill 61254d2b1d * Fix libavcodec library name detection, so we don't later try to
dlopen("-lavcodec.51").
* Disable h263ffmpeg plugin as ekiga doesn't use it
* Pass LDFLAGS to plugins at linking time, so they get RPATH
* Use RTLD_NEXT on NetBSD in an attempt to find symbols in NEEDED
  libraries of the one we actually loaded (libavcodec).
2008-09-14 13:41:38 +00:00

13 lines
516 B
Text

$NetBSD: patch-plugins_video_H_263-1998_Makefile_in,v 1.1 2008/09/14 13:41:38 jmcneill Exp $
--- plugins/video/H.263-1998/Makefile.in.orig 2008-09-14 09:22:08.000000000 -0400
+++ plugins/video/H.263-1998/Makefile.in 2008-09-14 09:22:17.000000000 -0400
@@ -62,7 +62,7 @@
OBJECTS = $(addprefix $(OBJDIR)/,$(patsubst %.cxx,%.o,$(notdir $(SRCS))))
$(PLUGIN): $(OBJECTS)
- $(CXX) $(LDSO) $(DL_LIBS) -o $@ $^
+ $(CXX) $(LDSO) $(DL_LIBS) $(LDFLAGS) -o $@ $^
install:
mkdir -p $(DESTDIR)$(libdir)/$(VC_PLUGIN_DIR)