patch-af should have been part of the last changeset of devel/gps. The distinfo already reflects the change to this patch.
51 lines
1.7 KiB
Text
51 lines
1.7 KiB
Text
$NetBSD: patch-af,v 1.2 2011/10/20 06:02:08 marino Exp $
|
|
|
|
--- gnatlib/aclocal.m4.orig 2010-07-19 08:57:13.000000000 +0000
|
|
+++ gnatlib/aclocal.m4
|
|
@@ -401,7 +401,7 @@ AC_HELP_STRING(
|
|
;;
|
|
esac
|
|
|
|
- if test x$PYTHON_WIN32 == xyes; then
|
|
+ if test x$PYTHON_WIN32 = xyes; then
|
|
PYTHON_VERSION=$PYTHON_MAJOR_VERSION$PYTHON_MINOR_VERSION
|
|
PYTHON_DIR=${PYTHON_BASE}/libs
|
|
else
|
|
@@ -452,6 +452,18 @@ AC_HELP_STRING(
|
|
*-darwin* )
|
|
PYTHON_LIBS="-ldl -lm ${PYTHON_LIBS}"
|
|
;;
|
|
+ *-freebsd* )
|
|
+ PYTHON_LIBS="-lm -lutil ${PYTHON_LIBS}"
|
|
+ ;;
|
|
+ *-dragonfly* )
|
|
+ PYTHON_LIBS="-lm -lutil ${PYTHON_LIBS}"
|
|
+ ;;
|
|
+ *-netbsd* )
|
|
+ PYTHON_LIBS="-lm -lutil ${PYTHON_LIBS}"
|
|
+ ;;
|
|
+ *-openbsd* )
|
|
+ PYTHON_LIBS="-lm -lutil ${PYTHON_LIBS}"
|
|
+ ;;
|
|
x86_64-*-* )
|
|
PYTHON_LIBS="-Wl,-export-dynamic -lm -ldl ${PYTHON_LIBS}"
|
|
;;
|
|
@@ -460,9 +472,6 @@ AC_HELP_STRING(
|
|
;;
|
|
i[[3456]]86-*win32* | i[[3456]]86-*mingw32* | i[[3456]]86-*cygwin* )
|
|
;;
|
|
- *-freebsd* )
|
|
- PYTHON_LIBS="-lm -lutil ${PYTHON_LIBS}"
|
|
- ;;
|
|
esac
|
|
|
|
if test -f ${PYTHON_DIR}/libpython${PYTHON_VERSION}.a ; then
|
|
@@ -471,7 +480,7 @@ AC_HELP_STRING(
|
|
PYTHON_LIBS="-L${PYTHON_DIR} -lpython${PYTHON_VERSION} ${PYTHON_LIBS}"
|
|
fi
|
|
|
|
- if test x$PYTHON_WIN32 == xyes; then
|
|
+ if test x$PYTHON_WIN32 = xyes; then
|
|
PYTHON_CFLAGS="-I${PYTHON_BASE}/include"
|
|
else
|
|
PYTHON_CFLAGS="-I${PYTHON_BASE}/include/python${PYTHON_VERSION}"
|