23 lines
580 B
Text
23 lines
580 B
Text
$NetBSD: patch-ab,v 1.3 2007/06/12 22:20:09 joerg Exp $
|
|
|
|
--- configure.in.orig 2005-04-26 13:17:09.000000000 +0000
|
|
+++ configure.in
|
|
@@ -16,12 +16,14 @@ if test "x$M4" = "xnotfound"; then
|
|
AC_MSG_ERROR([M4 is required])
|
|
else
|
|
ac_m4_vers=`$M4 --version 2>/dev/null | head -1` ;
|
|
- ac_is_gnu_m4=`echo $ac_m4_vers | cut -d' ' -f1`;
|
|
- if test "x$ac_is_gnu_m4" = "xGNU"; then
|
|
+ case ${ac_m4_vers} in
|
|
+ *GNU*)
|
|
AC_MSG_RESULT([ found $ac_m4_vers at $M4 ])
|
|
- else
|
|
+ ;;
|
|
+ *)
|
|
AC_MSG_ERROR([ GNU M4 is needed ])
|
|
- fi
|
|
+ ;;
|
|
+ esac
|
|
fi
|
|
|
|
dnl check for bison, yacc won't help;
|