pkgsrc/graphics/tcm/patches/patch-ba
jtb 717d3eec39 Changes the names of the libraries created during the build --
"libtcmgui" instead of "libgui".  emulators/gpsim installs a libgui
which causes problems.  There may be conflicts with the other libs
(libglobal, libtable, etc). To be safe, rename them all similarly.

Get rid of the terrible configure script.  It saved a few patches, but
isn't worth the ugliness.
2001-05-10 23:35:27 +00:00

48 lines
1.4 KiB
Text

$NetBSD: patch-ba,v 1.1 2001/05/10 23:35:28 jtb Exp $
--- sd/pv/Makefile.orig Wed Dec 20 13:33:26 2000
+++ sd/pv/Makefile
@@ -17,32 +17,25 @@
PVOBJECTS = $(CPOBJECTS) $(DPOBJECTS)
tcmpv: $(PVOBJECTS) tcmpv.o
- $(PURIFY) $(CC) $(CFLAGS) $(PVOBJECTS) \
- -ldiagram -leditor -lguix $(LIB_DIR)/libglobal.a \
+ $(CXX) $(CXXFLAGS) $(PVOBJECTS) \
+ -ltcmdiagram -ltcmeditor -ltcmguix -ltcmglobal \
tcmpv.o -o $@ $(LDFLAGS) $(LDLIBS)
- chmod a+rx $@
- $(STRIP) $@
- $(MV) $@ $(BIN_DIR)
+ $(MV) -f $@ $(BIN_DIR)
libtcmpv.a: $(PVOBJECTS)
- $(AR) $@ $(PVOBJECTS)
- chmod a+rx $@
+ $(AR) cr $@ $(PVOBJECTS)
$(RANLIB) $@
- $(MV) $@ $(LIB_DIR)
+ $(MV) -f $@ $(LIB_DIR)
tcpd: $(CPOBJECTS) cpeditor.o
- $(PURIFY) $(CC) $(CFLAGS) $(CPOBJECTS) cpeditor.o -o $@ \
- $(LDFLAGS) -ldiagram -leditor -lgui -lglobal $(LDLIBS)
- chmod a+rx $@
- $(STRIP) $@
- $(MV) $@ $(BIN_DIR)
+ $(CXX) $(CXXFLAGS) $(CPOBJECTS) cpeditor.o -o $@ \
+ $(LDFLAGS) -ltcmdiagram -ltcmeditor -ltcmgui -ltcmglobal $(LDLIBS)
+ $(MV) -f $@ $(BIN_DIR)
tdpd: $(PVOBJECTS) dpeditor.o
- $(PURIFY) $(CC) $(CFLAGS) $(PVOBJECTS) dpeditor.o -o $@ \
- $(LDFLAGS) -ldiagram -leditor -lgui -lglobal $(LDLIBS)
- chmod a+rx $@
- $(STRIP) $@
- $(MV) $@ $(BIN_DIR)
+ $(CXX) $(CXXFLAGS) $(PVOBJECTS) dpeditor.o -o $@ \
+ $(LDFLAGS) -ltcmdiagram -ltcmeditor -ltcmgui -ltcmglobal $(LDLIBS)
+ $(MV) -f $@ $(BIN_DIR)
clean: xclean