16 lines
512 B
Text
16 lines
512 B
Text
$NetBSD: patch-aa,v 1.3 2006/01/02 18:08:35 joerg Exp $
|
|
|
|
--- src/Makefile.shlib.orig 2001-11-11 19:20:53.000000000 +0000
|
|
+++ src/Makefile.shlib
|
|
@@ -137,6 +137,11 @@ ifeq ($(PORTNAME), bsdi)
|
|
endif
|
|
endif
|
|
|
|
+ifeq ($(PORTNAME), dragonfly)
|
|
+ shlib := lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION).$(SO_MINOR_VERSION)
|
|
+ LINK.shared = $(COMPILER) -shared -Wl,-x,-soname,$(soname)
|
|
+endif
|
|
+
|
|
ifeq ($(PORTNAME), freebsd)
|
|
ifdef ELF_SYSTEM
|
|
shlib := lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
|