pkgsrc/devel/cvs/patches/patch-av
2000-02-11 00:06:35 +00:00

91 lines
2.3 KiB
Text

$NetBSD: patch-av,v 1.2 2000/02/11 00:06:36 jlam Exp $
--- configure.in.orig Tue Jun 2 13:29:56 1998
+++ configure.in Thu Feb 10 18:53:22 2000
@@ -168,6 +168,9 @@
AC_DEFINE(HAVE_CONNECT)
fi])
+includeopt=
+AC_SUBST(includeopt)
+
dnl
dnl set $(KRB4) from --with-krb4=value -- WITH_KRB4
dnl
@@ -175,16 +178,19 @@
dnl libkrb in the system libraries, so --with-krb4=value needs to
dnl override the system -lkrb.
dnl
-KRB4=/usr/kerberos
+KRB4=
define(WITH_KRB4,[
AC_ARG_WITH([krb4],
[ --with-krb4=value set default \$(KRB4) from value],
- [KRB4=$withval],
+ [if test X"$withval" != X"no"; then KRB4=$withval; fi],
)dnl
-echo "default place for krb4 is $KRB4"
+if test X"$KRB4" != X""; then
+ echo "default place for krb4 is $KRB4"
+fi
AC_SUBST(KRB4)])dnl
WITH_KRB4
+if test X"$KRB4" != X""; then
krb_h=
AC_MSG_CHECKING([for krb.h])
if test "$cross_compiling" != yes && test -r $KRB4/include/krb.h; then
@@ -213,8 +219,6 @@
fi
AC_MSG_RESULT($krb_h)
-includeopt=
-AC_SUBST(includeopt)
if test -n "$krb_h"; then
krb_lib=
if test "$cross_compiling" != yes && test -r $KRB4/lib/libkrb.a; then
@@ -246,20 +250,24 @@
fi
fi
AC_CHECK_FUNCS(krb_get_err_text)
+fi # KRB4 empty
dnl
dnl Use --with-gssapi=DIR to enable GSSAPI support.
dnl
-GSSAPI=/usr/cygnus/kerbnet
+GSSAPI=
define(WITH_GSSAPI,[
AC_ARG_WITH([gssapi],
[ --with-gssapi=value GSSAPI directory],
- [GSSAPI=$withval],
+ [if test X"$withval" != X"no"; then GSSAPI=$withval; fi],
)dnl
-echo "default place for GSSAPI is $GSSAPI"
+if test X"$GSSAPI" != X""; then
+ echo "default place for GSSAPI is $GSSAPI"
+fi
AC_SUBST(GSSAPI)])dnl
WITH_GSSAPI
+if test X"$GSSAPI" != X""; then
hold_cppflags=$CPPFLAGS
CPPFLAGS="$CPPFLAGS -I$GSSAPI/include "
AC_CHECK_HEADERS(gssapi.h gssapi/gssapi.h gssapi/gssapi_generic.h)
@@ -272,7 +280,7 @@
if test "$ac_cv_header_gssapi_h" = "yes"; then
LIBS="$LIBS -L$GSSAPI/lib -lgssapi -lkrb5 -lasn1 -ldes -lroken"
else
- LIBS="$LIBS -L$GSSAPI/lib -lgssapi_krb5 -lkrb5 -lcrypto -lcom_err"
+ LIBS="$LIBS -L$GSSAPI/lib -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err"
fi
save_CPPFLAGS=$CPPFLAGS
CPPFLAGS="-I$GSSAPI/include $CPPFLAGS"
@@ -286,6 +294,7 @@
# there, an_to_ln.o refers to things defined only in -lgen.
AC_CHECK_LIB(gen, compile)
fi
+fi # GSSAPI empty
dnl
dnl Use --with-encryption to turn on encryption support