pkgsrc/lang/openjdk7/patches/patch-ag
jperkin 8fb76ee717 Add SunOS/GCC support. With huge thanks to "jesse" from #SmartOS who did the
bulk of the porting work.  Tested on SmartOS 32-bit.  64-bit builds currently
fail, they should hopefully be fixed soon.
2013-06-15 09:31:05 +00:00

15 lines
497 B
Text

$NetBSD: patch-ag,v 1.3 2013/06/15 09:31:05 jperkin Exp $
X rpath.
--- jdk/make/launchers/Makefile.launcher.orig 2012-08-10 17:21:41.000000000 +0000
+++ jdk/make/launchers/Makefile.launcher
@@ -164,7 +164,7 @@ ifeq ($(GUI_TOOL),true)
ifneq ($(PLATFORM), windows)
ifneq ($(PLATFORM), macosx)
# Anything with a GUI needs X11 to be linked in.
- OTHER_LDLIBS += -L$(OPENWIN_LIB) -lX11
+ OTHER_LDLIBS += -Wl,-R$(OPENWIN_LIB) -L$(OPENWIN_LIB) -lX11
endif
endif
endif