582da8ddb5
0.8.2 Changes - Improved yank and undo alloc'ing. Malloc as much we need from start in a long batch and avoid small mallocs. - Changed the way lua scripts are referenced in formulas. Now they are input as any other string formula, like this: \"@lua("script_name.lua", 1) being 1 if the reference should be added to the depgraph or not, making it evaluated just once or every time the depgraph is evaluated. NOTE that if set to 0 and the cell is referenced by another cell, it will be executed nonetheless. - Added new exec_lua configuration variable. - Rows now can have height higher than one LINE. See fj and fk in normal mode or :formatrow in command mode. - Wrap cell content. new autowrap config value. works when nooverlap and notruncate are set. - Open URL or file specified on cell (PR 401) - Import mkd files - Multiple frozen rows/columns (fr / fc in normal mode) - Added mapping_timeout configuration variable with a default value of 1500ms (used to be a fixed value of 800ms). - Added mouse support in insert and command mode. The selection of a cell gets copied to inputbar. - Added command_timeout configuration variable. - handle hidden rows/cols in undo/redo of ir/ic/dr/dc - Added backwards search with '?' - Restore \\* from old SC. \\{char} fills the cell with n occurrences of {char} to complete its width - Store frozen rows and cols when saving file - Added :formatcol command (handling its undo as well) - Added :formatrow command (handling its undo as well) - Added undo of freeze row and col - Handle \n in cell input, and with autowrap - Handle undoing changes in row height produced by string input - Changed input bar from window to pad: permits entering string longer than COLS. - @count counts cells with strings as well, and not just with numbers. - Handle entering a label after :datefmt for datetime value edition. - New dracula / papercolor themes. - Added EvalRange() so that the graph is not evaluated entirely all the time. - Replaced 'EvalAll' with 'EvalRange'. - Removed unneeded parameters on EvalJustVertex" - Added eval_order in EvalRange and rebuild_graph. - Added @evaluate / @sevaluate functions - Handle @nval dependencies. - Handle @mycol/@myrow calls during startup when no EvalJustOneVertex is yet called - Added @getent (FR issue #451) - The saving format for :w command would be according to current file format. #493 - modified savefile() of file.c to check current file format before saving a file. - Keep consistent with other format such as csv and save the file with the same format as current file. - Added HELP_HIGHLIGHT definition color for help page. - Renamed GRID_PAIR to GRID_EVEN in color.c. - UNDO of :fsum is handled by let. - calc_offscr_rows/cols rewriten and renamed to calc_mobile_rows/cols Fixes - Fix old sc bug - issue #371 - Fix when saving sc files of cells that has some string expressions - issue #541 - Fix leak in nval. - Fix Issue #372. - Free lua memory at exit. - Fix when saving marks in file after importing xlsx file and saving it in sc format. - EXPR and NUMBER colors were overloaded by STRING color #546 - Fix markdown export when empty col was added left to data - Fix in :showrows command. - :fsum added to command mode commands. It was missing. - Added :showcols command that was missing. - Handled issue #429 - handled issue #374 - Ignore SIGWINCH outside ncurses. - triggers: Avoid segfault when not being able to load module. Issue #325 0.8.1 New features - Braille support - Added latex export - issue #394 - Added mappings for command mode - Work on issues #225 and #247: support mapping of ñ and other special chars - Basic ODS file import - Paste to a range of selected cells - (actually added on v0.8 - issue 438 - PR 445) - Added txtdelim | for csv files import - issue 409 - Added macros to --version (show version) - Support higher versions of lua. - Handle ESC key in mappings. related to issue #492. - Added freeze to visual mode - issue #459 Changes - Recognise SPACE in mappings rather than simple ' ' - Visual change: Moved cmd multiplier to the left of mode - Changed default headings colors - many improvements to the config facility and usage - PR 519 - improved sort for 65k rows Fixes - Fix issues on CIRCULAR REFERENCES: #473 #201 #475 #321. these were as hard. - Fix issue 417 and added a date type in xlsx import. - Fix Engformat overlap text y número. Mostraba * (actually fixed on v0.8) - Fix column header display - overflow with column width 2 and column with two letters - PR 517 - Fix isnumeric test to recognise floats: affects copy/paste - PR 450 - Fix issue setting conf variables like nonumeric - Fix when showing empty text - 944844505d7cdb7d3d392a5c1d2b3ffde40a1fff - Fix issue #227 - this was hard. used to segfault and keep wrong reference after deleting row that is last in range of expr. ex. @avg(B1:B4) and deleting row 4 - Fix issue #433: large memory use with multiple linked cells. - Fix issue #287 - valueize didnt update depgraph - Solved issue #399. 'g' command of NORMAL_MODE changed to 'gt'" - Fixed vmaps in get_mappings function. - Fixed bug on 'error' in gram.y - comment on issue #482 - Fix issue #457: cursor position could add empty rows or columns when exporting csv files - Fix issue #288: ^ misbehaving when having fixed rows - Fix in mouse clicks - Fix possible memory leak in add freeze - XLSX: Free memory leak when looking for specified sheet. - XLSX: Avoid segfault when using shared formulas. issue #218.
79 lines
2.6 KiB
Text
79 lines
2.6 KiB
Text
$NetBSD: patch-src_Makefile,v 1.3 2021/07/26 01:38:05 sjmulder Exp $
|
|
|
|
- Make libdl and curses flags overridable
|
|
- Make color support opt in so we can control it
|
|
- Remove hardcoded paths for NetBSD
|
|
|
|
--- src/Makefile.orig 2021-05-13 17:38:26.000000000 +0000
|
|
+++ src/Makefile
|
|
@@ -37,7 +37,7 @@ CFLAGS += -DDFLT_PAGER=\"less\"
|
|
# Sets default editor. Its use in case EDITOR env variable is not set
|
|
CFLAGS += -DDFLT_EDITOR=\"vim\"
|
|
# Comment out to disable color support
|
|
-CFLAGS += -DUSECOLORS
|
|
+#CFLAGS += -DUSECOLORS
|
|
# Command history file, relative to HISTORY_DIR directory. Comment out to disable commandline history
|
|
CFLAGS += -DHISTORY_FILE=\"$(HISTORY_FILE)\" -DHISTORY_DIR=\"$(HISTORY_DIR)\"
|
|
# Configuration file, relative to CONFIG_DIR directory
|
|
@@ -94,25 +94,27 @@ endif
|
|
|
|
# dynamic linking (not available in BSD)
|
|
ifneq ($(shell uname -s | grep -o BSD),BSD)
|
|
- LDLIBS += -ldl
|
|
+ LDLIBS_DL += -ldl
|
|
endif
|
|
|
|
+LDLIBS += $(LDLIBS_DL)
|
|
+
|
|
ifneq (, $(shell which pkg-config))
|
|
# Any system with pkg-config
|
|
|
|
# NOTE: ncursesw (required)
|
|
ifeq ($(shell uname -s),Darwin)
|
|
# macOS' ncurses is built with wide-char support
|
|
- LDFLAGS += -lncurses
|
|
+ LDLIBS_CURSES ?= -lncurses
|
|
else ifneq ($(shell pkg-config --exists ncursesw || echo 'no'),no)
|
|
- CFLAGS += $(shell pkg-config --cflags ncursesw)
|
|
- LDLIBS += $(shell pkg-config --libs ncursesw)
|
|
+ CFLAGS_CURSES ?= $(shell pkg-config --cflags ncursesw)
|
|
+ LDLIBS_CURSES ?= $(shell pkg-config --libs ncursesw)
|
|
else ifneq ($(shell pkg-config --exists ncurses || echo 'no'),no)
|
|
# hopefully this includes wide character support then
|
|
- CFLAGS += $(shell pkg-config --cflags ncurses)
|
|
- LDLIBS += $(shell pkg-config --libs ncurses)
|
|
+ CFLAGS_CURSES ?= $(shell pkg-config --cflags ncurses)
|
|
+ LDLIBS_CURSES ?= $(shell pkg-config --libs ncurses)
|
|
else
|
|
- LDLIBS += -lncursesw
|
|
+ LDLIBS_CURSES ?= -lncursesw
|
|
endif
|
|
|
|
# NOTE: libxlsreader (libxls) is required for xls file reading support
|
|
@@ -153,21 +155,14 @@ else ifeq ($(shell uname -s),Darwin)
|
|
# macOS without pkg-config
|
|
|
|
# macOS' ncurses is built with wide-char support
|
|
- LDFLAGS += -lncurses
|
|
-else ifeq ($(shell uname -s),NetBSD)
|
|
- # NetBSD without pkg-config
|
|
-
|
|
- CFLAGS += -I/usr/pkg/include
|
|
- CFLAGS += -I/usr/pkg/include/ncursesw
|
|
-
|
|
- LDFLAGS += -L/usr/pkg/lib
|
|
- LDFLAGS += -Wl,-R/usr/pkg/lib
|
|
-
|
|
- LDLIBS += -lncursesw
|
|
+ LDLIBS_CURSES += -lncurses
|
|
else
|
|
- LDFLAGS += -lncursesw
|
|
+ LDLIBS_CURSES += -lncursesw
|
|
endif
|
|
|
|
+CFLAGS += $(CFLAGS_CURSES)
|
|
+LDLIBS += $(LDLIBS_CURSES)
|
|
+
|
|
OBJS = $(patsubst %.c, %.o, $(wildcard *.c) $(wildcard utils/*.c)) gram.o
|
|
|
|
.PHONY : all clean install docs man_install man_uninstall
|