(from commit log of perl5-current/Makefile): * Interpreter cloning, threads, and concurrency * Lexically scoped warning categories * Unicode and UTF-8 support * Support for interpolating named characters * "our" declarations * Support for strings represented as a vector of ordinals * Improved Perl version numbering system * New syntax for declaring subroutine attributes * File and directory handles can be autovivified * open() with more than two arguments * 64-bit support * Large file support * Long doubles * "more bits" * Enhanced support for sort() subroutines * C<sort $coderef @foo> allowed * File globbing implemented internally * POSIX character class syntax [: :] supported * Improved C<qw//> operator * pack() format 'Z' supported * pack() format modifier '!' supported * pack() and unpack() support counted strings * Comments in pack() templates * Weak references * Binary numbers supported * Lvalue subroutines * Some arrows may be omitted in calls through references * Boolean assignment operators are legal lvalues * exists() is supported on subroutine names * exists() and delete() are supported on array elements * Pseudo-hashes work better * Automatic flushing of output buffers * Better diagnostics on meaningless filehandle operations * Where possible, buffered data discarded from duped input filehandle * eof() has the same old magic as <> * binmode() can be used to set :crlf and :raw modes * C<-T> filetest recognizes UTF-8 encoded files as "text" * system(), backticks and pipe open now reflect exec() failure * Improved diagnostics * Diagnostics follow STDERR * syswrite() ease-of-use * Better syntax checks on parenthesized unary operators * Bit operators support full native integer width * Improved security features * C<require> and C<do> may be overridden * $^X variables may now have names longer than one character * New variable $^C reflects C<-c> switch * New variable $^V contains Perl version as a string * Optional Y2K warnings * Modules * Pragmata * dprofpp * find2perl * h2xs * perlcc * perldoc * The Perl Debugger * Simple sort() using { $a <=> $b } and the like are optimized * Optimized assignments to lexical variables * Faster subroutine calls * -Dusethreads means something different * New Configure flags * Threadedness and 64-bitness now more daring * Long Doubles ... See 'perldoc perldelta' for a full list.
26 lines
973 B
Text
26 lines
973 B
Text
$NetBSD: patch-af,v 1.9 2000/08/30 18:42:24 jlam Exp $
|
|
|
|
--- utils/Makefile.orig Mon Sep 6 15:46:15 1999
|
|
+++ utils/Makefile
|
|
@@ -5,9 +5,9 @@
|
|
# Files to be built with variable substitution after miniperl is
|
|
# available. Dependencies handled manually below (for now).
|
|
|
|
-pl = c2ph.PL h2ph.PL h2xs.PL perlbug.PL perldoc.PL pl2pm.PL splain.PL perlcc.PL dprofpp.PL
|
|
-plextract = c2ph h2ph h2xs perlbug perldoc pl2pm splain perlcc dprofpp
|
|
-plextractexe = c2ph.exe h2ph.exe h2xs.exe perlbug.exe perldoc.exe pl2pm.exe splain.exe perlcc.exe dprofpp.exe
|
|
+pl = c2ph.PL h2ph.PL h2xs.PL perlbug.PL perldoc.PL pl2pm.PL splain.PL perlcc.PL
|
|
+plextract = c2ph h2ph h2xs perlbug perldoc pl2pm splain perlcc
|
|
+plextractexe = c2ph.exe h2ph.exe h2xs.exe perlbug.exe perldoc.exe pl2pm.exe splain.exe perlcc.exe
|
|
|
|
all: $(plextract)
|
|
|
|
@@ -32,8 +32,6 @@
|
|
splain: splain.PL ../config.sh ../lib/diagnostics.pm
|
|
|
|
perlcc: perlcc.PL ../config.sh
|
|
-
|
|
-dprofpp: dprofpp.PL ../config.sh
|
|
|
|
clean:
|
|
|