pkgsrc/devel/sdcc/patches/patch-aa
2012-05-05 21:33:55 +00:00

32 lines
1.4 KiB
Text

$NetBSD: patch-aa,v 1.9 2012/05/05 21:33:55 dholland Exp $
- avoid installing various trash files
- use find correctly when doing so
- stop on error when doing so
--- device/lib/Makefile.in.orig 2007-06-03 20:38:18.000000000 +0000
+++ device/lib/Makefile.in
@@ -352,16 +352,18 @@ install: all installdirs
for src in $(MODELS) ds390 ds400 gbz80 z80 hc08 pic pic16; do \
find $(sdcc_libdir)/src/$$src -depth \
- \( -name '*.rel' -o -name '*.dump*' -o -name '*.sym' -o -name '*.o' -o -name '*.lib' -o \
- -name '*.lst' -o -name '*.asm' -o -name '.svn' -o -name 'build' -o -name 'bin' -o \
- -name 'Makefile*' \) \
- -exec rm -rf {}+ \; ; \
+ \( -name '*.rel' -o -name '*.dump*' -o -name '*.sym' -o -name '*.o' -o -name '*.lib' -o \
+ -name '*.lst' -o -name '*.asm' -o -name '.svn' -o -name 'autom4te.cache' -o \
+ -name 'build' -o -name 'bin' -o -name 'Makefile*' -o -name 'config*' -o \
+ -name 'depcomp' -o -name 'missing' -o -name 'install-sh' -o \
+ -name 'bootstrap.sh' \) \
+ -exec rm -rf {} + || exit 1; \
done
find $(sdcc_libdir)/src/mcs51 -depth \
\( -name '*.rel' -o -name '*.dump*' -o -name '*.sym' -o -name '*.o' -o -name '*.lib' -o \
-name '*.lst' -o -name '.svn' -o -name 'build' -o -name 'bin' -o \
-name 'Makefile*' \) \
- -exec rm -rf {}+ \;
+ -exec rm -rf {} +
# Deleting all the installed files
# --------------------------------