eb65092610
version 20050616 (Figwort) include: - ENHANCE: API function arguments are now const where appropriate, to match corresponding changes in the Solaris PAM and Linux-PAM APIs. - ENHANCE: corrected a number of C namespace violations. - ENHANCE: the module cache has been removed, allowing long-lived applications to pick up module changes. This also allows multiple threads to use PAM simultaneously (as long as they use separate PAM contexts), since the module cache was the only part of OpenPAM that was not thread-safe.
21 lines
619 B
Text
21 lines
619 B
Text
$NetBSD: patch-ac,v 1.3 2008/02/18 16:48:12 jlam Exp $
|
|
|
|
--- lib/Makefile.in.orig 2007-12-21 06:44:28.000000000 -0500
|
|
+++ lib/Makefile.in
|
|
@@ -116,7 +116,7 @@ CC = @CC@
|
|
CCDEPMODE = @CCDEPMODE@
|
|
CFLAGS = @CFLAGS@
|
|
CPP = @CPP@
|
|
-CPPFLAGS = @CPPFLAGS@
|
|
+CPPFLAGS = @CPPFLAGS@ -DSYSCONFDIR=\"$(sysconfdir)\"
|
|
CRYPT_LIBS = @CRYPT_LIBS@
|
|
CXX = @CXX@
|
|
CXXCPP = @CXXCPP@
|
|
@@ -267,7 +267,6 @@ libpam_la_SOURCES = \
|
|
pam_vprompt.c \
|
|
$(NULL)
|
|
|
|
-libpam_la_CFLAGS = -DOPENPAM_MODULES_DIR='"@OPENPAM_MODULES_DIR@/"'
|
|
libpam_la_LDFLAGS = -no-undefined -version-info @LIB_MAJ@ @DL_LIBS@
|
|
EXTRA_DIST = \
|
|
pam_authenticate_secondary.c \
|