pkgsrc/databases/mysql57-client/patches/patch-storage_blackhole_CMakeLists.txt
adam 7cb1f0a9d9 MySQL is a SQL (Structured Query Language) database server. SQL is the most
popular database language in the world. MySQL is a client-server implementation
that consists of a server daemon `mysqld' and many different client
programs/libraries.

The main goals of MySQL are speed and robustness.

The base upon which MySQL is built is a set of routines that have been used in
a highly demanding production environment for many years.  While MySQL is still
in development it already offers a rich and highly useful function set.
2016-09-16 06:49:11 +00:00

12 lines
437 B
Text

$NetBSD: patch-storage_blackhole_CMakeLists.txt,v 1.1 2016/09/16 06:49:11 adam Exp $
Build with newer DTrace.
--- storage/blackhole/CMakeLists.txt.orig 2016-03-28 18:06:12.000000000 +0000
+++ storage/blackhole/CMakeLists.txt
@@ -15,4 +15,4 @@
SET(BLACKHOLE_SOURCES ha_blackhole.cc ha_blackhole.h)
MYSQL_ADD_PLUGIN(blackhole ${BLACKHOLE_SOURCES} STORAGE_ENGINE
-RECOMPILE_FOR_EMBEDDED)
+RECOMPILE_FOR_EMBEDDED DTRACE_INSTRUMENTED)