4b20d2b934
* Packages must have been installed under R >= 2.10.0, as the current help system is the only one now supported. * A port to 64-bit Windows is now available as well as binary package repositiories: see the 'R Administration and Installation Manual'. * Argument matching for primitive functions is now done in the same way as for interpreted functions except for the deliberate exceptions call switch .C .Fortran .Call .External all of which use positional matching for their first argument, and also some internal-use-only primitives. * The default device for command-line R at the console on Mac OS X is now quartz() and not X11(). New features * The 'open' modes for connections are now interpreted more consistently. * R CMD INSTALL now uses the internal untar() in package utils. * help(try.all.packages = TRUE) is much faster. * R CMD check has a new option '--timings' to record per-example timings in file <pkg>.Rcheck/<pkg>-Ex.timings. * The TRE library has been updated to version 0.8.0 (minor bugfixes). More...
20 lines
1,007 B
Text
20 lines
1,007 B
Text
$NetBSD: patch-ad,v 1.14 2010/05/06 07:33:41 adam Exp $
|
|
|
|
--- src/main/Makefile.in.orig 2010-03-25 08:32:02.000000000 +0000
|
|
+++ src/main/Makefile.in
|
|
@@ -96,13 +96,13 @@ EXTRA_STATIC_LIBS = \
|
|
$(R_ZLIBS) $(R_BZLIBS) $(R_PCRE) $(R_TRE) $(R_XDR) $(R_XZ) $(R_LIBINTL)
|
|
STATIC_LIBS = $(MAIN_LIBS) $(EXTRA_STATIC_LIBS)
|
|
|
|
-EXTRA_LIBS = $(BLAS_LIBS) $(FLIBS) $(R_XTRA_LIBS) @LIBINTL@ $(READLINE_LIBS) $(LIBS)
|
|
+EXTRA_LIBS = $(BLAS_LIBS) $(FLIBS) $(R_XTRA_LIBS) @LIBINTL@ $(READLINE_LIBS) $(LIBS) @LIBMULTITHREAD@
|
|
|
|
R_binary = R.bin
|
|
R_bin_OBJECTS = Rmain.o
|
|
@WANT_R_SHLIB_FALSE@R_bin_LDADD = libR.a $(EXTRA_LIBS)
|
|
## Linked against -lRblas becasue -lR is and otherwise ld complains.
|
|
-@WANT_R_SHLIB_TRUE@R_bin_LDADD = -L../../lib@R_ARCH@ -lR @BLAS_SHLIB_TRUE@-lRblas
|
|
+@WANT_R_SHLIB_TRUE@R_bin_LDADD = -L../../lib@R_ARCH@ ${COMPILER_RPATH_FLAG}$(Rexeclibdir) -lR @BLAS_SHLIB_TRUE@-lRblas
|
|
R_bin_DEPENDENCIES =@WANT_R_SHLIB_FALSE@ libR.a @USE_EXPORTFILES_TRUE@ $(top_builddir)/etc/R.exp
|
|
|
|
libR_la = libR$(DYLIB_EXT)
|