pkgsrc/graphics/pcl/patches/patch-examples_keypoints_CMakeLists.txt
thor 93ca69daa3 graphics/pcl: enable visualization using VTK
This is a very common use-case and thus VTK is on by default. As there
are cases where you just need PCL for the data formats and algorithms,
it can be disabled.

There is another change pending to add Qt support to VTK, which will
be inherited here, as I am told the (a?) standard use case for VTK is via
Qt. The option is: Either just computations (headless) or the full
visualization stuff.
2021-05-07 11:36:29 +00:00

23 lines
668 B
Text

$NetBSD: patch-examples_keypoints_CMakeLists.txt,v 1.1 2021/05/07 11:36:29 thor Exp $
Support VTK 9, from PR 4262
--- examples/keypoints/CMakeLists.txt.orig 2020-08-14 12:23:03.000000000 +0000
+++ examples/keypoints/CMakeLists.txt
@@ -6,12 +6,11 @@ PCL_SUBSYS_DEPEND(build ${SUBSYS_NAME} D
## Find VTK
if(NOT VTK_FOUND)
- set(DEFAULT FALSE)
- set(REASON "VTK was not found.")
+ set(DEFAULT FALSE)
+ set(REASON "VTK was not found.")
else()
- set(DEFAULT TRUE)
- set(REASON)
- include(${VTK_USE_FILE})
+ set(DEFAULT TRUE)
+ set(REASON)
endif()
PCL_ADD_EXAMPLE(pcl_example_sift_keypoint_estimation FILES example_sift_keypoint_estimation.cpp