34 lines
1.2 KiB
Text
34 lines
1.2 KiB
Text
$NetBSD: patch-ab,v 1.4 2002/08/19 18:57:59 mycroft Exp $
|
|
|
|
--- configure.in.orig Mon Aug 5 18:30:55 2002
|
|
+++ configure.in Mon Aug 12 18:35:45 2002
|
|
@@ -403,16 +403,16 @@
|
|
esac
|
|
fi
|
|
|
|
-dnl check for openbsd audio
|
|
+dnl check for netbsd/openbsd audio
|
|
AC_ARG_ENABLE([obsdaudio],
|
|
- [ --disable-obsdaudio make a version not using OpenBSD audio])
|
|
+ [ --disable-obsdaudio make a version not using NetBSD/OpenBSD audio])
|
|
if test "x$enable_obsdaudio" != xno; then
|
|
case "$host" in
|
|
- *-openbsd*)
|
|
+ *-netbsd*|*-openbsd*)
|
|
|
|
dnl only define LIBOGLEAO_OBSD headers found
|
|
dnl sys/audioio.h
|
|
- AC_DEFINE([LIBOGLEAO_OBSD],,[libogleao OpenBSD audio support])
|
|
+ AC_DEFINE([LIBOGLEAO_OBSD],,[libogleao NetBSD/OpenBSD audio support])
|
|
BUILD_AUDIO_OBSD=1
|
|
DEFAULT_AUDIO_DRIVER="obsd"
|
|
DEFAULT_AUDIO_DEVICE="/dev/audio"
|
|
@@ -425,7 +425,7 @@
|
|
[ --disable-sunaudio make a version not using Sun audio])
|
|
if test "x$enable_sunaudio" != xno; then
|
|
case "$host" in
|
|
- *-sun-solaris*|*-netbsd*)
|
|
+ *-sun-solaris*)
|
|
|
|
dnl check for headers.. only define LIBOGLEAO_SOLARIS if headers are found.
|
|
AC_DEFINE([LIBOGLEAO_SOLARIS],,[libogleao solaris audio support])
|