d62c883615
Lots of changes, notably now it uses Linux-2.6.11.x, a NetBSD bug was fixed. pkgsrc changes: * Honor PKG_SYSCONFDIR and SUPPORT_FILES for configuration files. * xend.sh: no more python warning messages when the script is used on non NetBSD/Xen systems.
22 lines
571 B
Text
22 lines
571 B
Text
$NetBSD: patch-ad,v 1.2 2005/05/24 16:02:08 xtraeme Exp $
|
|
|
|
--- xfrd/Makefile.orig 2005-05-24 00:25:29.000000000 +0000
|
|
+++ xfrd/Makefile 2005-05-24 00:26:27.000000000 +0000
|
|
@@ -11,7 +11,7 @@
|
|
XEN_ROOT = ../..
|
|
include $(XEN_ROOT)/tools/Rules.mk
|
|
|
|
-XFRD_INSTALL_DIR = /usr/sbin
|
|
+XFRD_INSTALL_DIR = $(PREFIX)/sbin
|
|
|
|
vpath %.h $(XEN_LIBXC)
|
|
INCLUDES += -I $(XEN_LIBXC)
|
|
@@ -50,7 +50,7 @@
|
|
XFRD_LIBS :=
|
|
|
|
XFRD_LIBS += -L $(XEN_LIBXC) -lxc
|
|
-XFRD_LIBS += -L $(XEN_LIBXUTIL) -lxutil
|
|
+XFRD_LIBS += -L $(XEN_LIBXUTIL) $(LDFLAGS) -lxutil
|
|
|
|
# zlib library.
|
|
XFRD_LIBS += -lz
|