Fixes issues the with autoconf 2.70 update and bison POSIX yacc errors. Major changes in 1.18.3 (2020-11-17) ------------------------------------ This is a bug fix release. * Fix a denial of service vulnerability when decoding Kerberos protocol messages. * Fix a locking issue with the LMDB KDB module which could cause KDC and kadmind processes to lose access to the database. * Fix an assertion failure when libgssapi_krb5 is repeatedly loaded and unloaded while libkrb5support remains loaded. krb5-1.18.3 changes by ticket ID -------------------------------- 7476 updated manual page for kvno 8614 Assertion failure when repeatedly loading libgssapi_krb5 8882 kdb5_util load ignores password expiration with LDAP KDB module 8918 KDC and kadmind fork with DB open, breaking LMDB KDB module 8926 Allow gss_unwrap_iov() of unpadded RC4 tokens 8933 Fix input length checking in SPNEGO DER decoding 8936 Set lockdown attribute when creating LDAP KDB 8938 Leash crashes on failure to auto-renew tickets 8939 Suppress Leash error popup on MSLSA renew failure 8959 Add recursion limit for ASN.1 indefinite lengths 8960 Fix compatibility with upcoming autoconf 2.70
15 lines
437 B
Text
15 lines
437 B
Text
$NetBSD: patch-plugins_kdb_ldap_ldap__util_Makefile.in,v 1.1 2021/01/16 09:00:23 jperkin Exp $
|
|
|
|
Pass YFLAGS.
|
|
|
|
--- plugins/kdb/ldap/ldap_util/Makefile.in.orig 2020-11-17 17:17:59.000000000 +0000
|
|
+++ plugins/kdb/ldap/ldap_util/Makefile.in
|
|
@@ -19,7 +19,7 @@ $(PROG): $(OBJS) $(KADMSRV_DEPLIBS) $(KR
|
|
|
|
getdate.c: $(GETDATE)
|
|
$(RM) getdate.c y.tab.c
|
|
- $(YACC) $(GETDATE)
|
|
+ $(YACC) $(YFLAGS) $(GETDATE)
|
|
$(MV) y.tab.c getdate.c
|
|
|
|
install:
|