pkgsrc/security/zoneminder/patches/patch-src_zm_remote_camera_h
dsainty 3205b33802 Update ZoneMinder from 1.25.0 to 1.28.1.
Numerous changes, documented at:
 https://github.com/ZoneMinder/ZoneMinder/releases

Addresses two security advisories:

  https://github.com/ZoneMinder/ZoneMinder/releases/tag/v1.28.0
  http://secunia.com/advisories/62918/

Pkgsrc changes:

patch-src_zm_signal_h is no longer necessary because zm_signal.h uses
HAVE_EXECINFO_H.

patch-src_zmf_cpp appears to be applied upstream.

patch-configure_ac no longer needs to set PATH_BUILD to
PREFIX/share/zoneminder, so that zmupdate.pl can locate the database build
scripts as installed files.  Upstream has now implemented this via the
ZM_PATH_DATA entry in zm.conf, and adds a ZM_PATH_DATA/db subdirectory.

src/Makefile.am no longer setuid's zmfix, as zmfix was removed from
ZoneMinder 1.26.6.

The code now uses clock_gettime(), which on some systems (like Linux), calls
for -lrt.  Since the build system isn't aware of this, but Pkgsrc is, just set
PTHREAD_AUTO_VARS=yes.

The PHP code now uses PDO for DB access, but it looks like there are some
straggling dependencies on the raw MySQL driver, so both are pulled in.
2015-04-05 08:51:08 +00:00

20 lines
507 B
Text

$NetBSD: patch-src_zm_remote_camera_h,v 1.4 2015/04/05 08:51:08 dsainty Exp $
Declare sockaddr_in.
--- src/zm_remote_camera.h.orig 2015-02-05 15:52:37.000000000 +1300
+++ src/zm_remote_camera.h 2015-04-01 17:56:10.736361360 +1300
@@ -23,10 +23,13 @@
#include "zm_camera.h"
#include "zm_rtsp_auth.h"
+#include <netinet/in.h>
+
#include <string>
#include <sys/types.h>
#include <sys/socket.h>
#include <netdb.h>
+#include <time.h>
//
// Class representing 'remote' cameras, i.e. those which are