08cca7e324
- fixed a bug when dragging files from Gnome (or other desktops?) to Xfe. The number of files was incorrectly set to n+1 instead of n. - fixed a small regression that occured when trying to copy or move a directory to a place where a directory with the same name already exists - simplified the source tree to reduce the compilation time Version 0.83 (not released) - modified the layout of the permissions tab to be more intuitive (first permissions, then owner, and finally command) - added button "Owner only" in the permissions tab to allow chown only operations - fixed a bug in chmod and chown operations when trying to recursively change permissions on a single folder - new Debian package icon - when multiple files are selected, the default for Properties/Permissions dialog is now "Set marked". This is more consistent with the single selected file case. - updated xfe.spec.in to reflect FOX 1.4.x support - changed executable files icon - added Windows EXE icon - added Ctrl-W shortcut to the Quit button - changed the font in Help window to text font (improve readability) - changed delete and empty trash icons, for consistency - fixed a problem when moving a file and that file already exists : only one overwrite dialog should appear. Fixed the File::move() function in the File class. - updated the README and help.cc files - implementation of the trash can for file delete operations - fixed a small bug in exists() function that prevent broken links to be deleted
45 lines
1.4 KiB
Text
45 lines
1.4 KiB
Text
$NetBSD: patch-aa,v 1.2 2005/07/25 10:55:44 adam Exp $
|
|
|
|
--- Makefile.in.orig 2005-06-24 08:38:22.000000000 +0000
|
|
+++ Makefile.in
|
|
@@ -159,8 +159,6 @@ man_MANS = xfe.1 xfv.1 xfi.1 xfq.1
|
|
SUBDIRS = intl po m4 src icons
|
|
DIST_SUBDIRS = intl po m4 src icons
|
|
|
|
-rcdir = $(prefix)/lib/foxrc
|
|
-rc_DATA = Desktop
|
|
|
|
EXTRA_DIST = autogen.sh config.h i18n.h xfe.1 xfv.1 xfi.1 xfq.1 \
|
|
ABOUT-NLS TODO FAQ BUGS xfe.spec.in Desktop.in xfe.png xfi.png xfq.png xfv.png \
|
|
@@ -180,7 +178,7 @@ DIST_SOURCES =
|
|
|
|
NROFF = nroff
|
|
MANS = $(man_MANS)
|
|
-DATA = $(icon_DATA) $(rc_DATA)
|
|
+DATA = $(icon_DATA)
|
|
|
|
|
|
RECURSIVE_TARGETS = info-recursive dvi-recursive pdf-recursive \
|
|
@@ -304,22 +302,8 @@ uninstall-iconDATA:
|
|
done
|
|
rcDATA_INSTALL = $(INSTALL_DATA)
|
|
install-rcDATA: $(rc_DATA)
|
|
- @$(NORMAL_INSTALL)
|
|
- $(mkinstalldirs) $(DESTDIR)$(rcdir)
|
|
- @list='$(rc_DATA)'; for p in $$list; do \
|
|
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
- f="`echo $$p | sed -e 's|^.*/||'`"; \
|
|
- echo " $(rcDATA_INSTALL) $$d$$p $(DESTDIR)$(rcdir)/$$f"; \
|
|
- $(rcDATA_INSTALL) $$d$$p $(DESTDIR)$(rcdir)/$$f; \
|
|
- done
|
|
|
|
uninstall-rcDATA:
|
|
- @$(NORMAL_UNINSTALL)
|
|
- @list='$(rc_DATA)'; for p in $$list; do \
|
|
- f="`echo $$p | sed -e 's|^.*/||'`"; \
|
|
- echo " rm -f $(DESTDIR)$(rcdir)/$$f"; \
|
|
- rm -f $(DESTDIR)$(rcdir)/$$f; \
|
|
- done
|
|
|
|
# This directory's subdirectories are mostly independent; you can cd
|
|
# into them and run `make' without going through this Makefile.
|