* The XEmacs Project announced that 21.4 is the official stable branch. 21.4.12 is the first release of the branch. The XEmacs 21.1 series is retired. * Changes new in 21.4 are as below * Changes in XEmacs 21.4 ======================== ** Summary of user-visible changes: -- The delete key now deletes forward by default. -- Shifted motion keys now select text by default. -- You can now build XEmacs with support for GTK+ widget set. -- ~/.xemacs/init.el is now the preferred location for the init file. - XEmacs now supports a `~/.xemacs/init.el' startup file. - Custom file will move to ~/.xemacs/custom.el. -- Much-improved sample init.el, showing how to use many useful features. -- XEmacs support for menu accelerators has been much improved. -- Default menubar improvements. - Default menubar has many new commands and better organization. - The font-menu is now available under MS Windows. -- Dialog box improvements, including a real file dialog box. - XEmacs now has a proper file dialog box under MS Windows (and GTK)! - The old clunky file dialog box is improved. - Keyboard traversal now works correctly in MS Windows dialog boxes. - There is a Search dialog box available from Edit->Find... -- New buffer tabs. -- There is a new MS Windows installer, netinstall, ported from Cygwin. -- The subprocess quote-handling mechanism under Windows is much improved. -- Printing support now available under MS Windows. -- Selection improvements. - Kill and yank now interact with the clipboard under Windows. - MS Windows support for selection is now much more robust. - Motif selection support is now more correct (but slower). -- Mail spool locking now works correctly. -- International support changes. - The default coding-priority-list is now safer. - International keysyms are now supported under X. - MS Windows 1251 code page now supported. - Czech, Thai, Cyrillic-KOI8, Vietnamese, Ethiopic now supported. - Proper support for words in Latin 3 and Latin 4. -- Help buffers contain hyperlinks, and other changes. -- The modeline's text is now scrollable. -- The mouse wheel under MS Windows now functions correctly. -- Interactive searching and matching case improvements. - Incremental search will now highlight all visible matches. - Interactive searches always respect uppercase characters. -- Rectangle functions rewritten to avoid inserting extra spaces. -- New command `kill-entire-line' that always kills the entire line. -- Default values correctly stored in minibuffer histories. -- You can now create "indirect buffers", like in GNU Emacs. -- Pixel-based scrolling has been implemented. -- Operation progress can be displayed using graphical widgets. -- User names following a tilde can now be completed at file name prompts. -- XEmacs can now play sound using Enlightenment Sound Daemon (ESD). -- X-Face support is now available under MS Windows. -- The PostgreSQL Relational Database Management System is now supported. -- Indentation no longer indents comments that begin at column zero. -- Face and variable settings can have comments in Customize. -- New locations for early package hierarchies. -- The `auto-save' library has been greatly improved. -- New variable `mswindows-alt-by-itself-activates-menu'. -- Other init-file-related changes. - Init file in your home directory may be called `.emacs.el'. - New command-line switches -user-init-file and -user-init-directory. -- Etags changes. - In DOS, etags looks for file.cgz if it cannot find file.c. - New option --ignore-case-regex is an alternative to --regex. - New option --declarations, for C-type languages. - In C++, tags are created for "operator". - Ada now supported. - In Fortran, procedure is no longer tagged. - In Java, tags are created for "interface". - In Lisp, def-type constructs are now tagged. - In Perl, the --globals option tags global variables. - Python now supported. - New file extensions recognized: .ss, .pdb, .psw.
44 lines
1.5 KiB
Text
44 lines
1.5 KiB
Text
$NetBSD: patch-af,v 1.4 2003/02/25 02:14:59 uebayasi Exp $
|
|
|
|
--- configure.in.orig Tue Jan 7 12:57:03 2003
|
|
+++ configure.in
|
|
@@ -1079,6 +1079,7 @@
|
|
|
|
dnl Straightforward machine determination
|
|
case "$canonical" in
|
|
+ arm-*-* ) machine=arm ;;
|
|
sparc-*-* ) machine=sparc ;;
|
|
alpha*-*-* ) machine=alpha ;;
|
|
vax-*-* ) machine=vax ;;
|
|
@@ -1157,10 +1158,10 @@
|
|
case "$canonical" in
|
|
i[[3-9]]86-*-netbsd*) machine=intel386 ;;
|
|
hp300-*-netbsd* | amiga-*-netbsd* | sun3-*-netbsd* | mac68k-*-netbsd* | da30-*-netbsd* | m68k-*-netbsd* )
|
|
- dnl Yes, this is somewhat bogus.
|
|
- machine=hp9000s300 ;;
|
|
+ machine=m68k ;;
|
|
pc532-*-netbsd* | ns32k-*-netbsd* ) machine=ns32000 ;;
|
|
pmax-*-netbsd* | mips-*-netbsd* ) machine=pmax ;;
|
|
+ alpha-*-netbsd* ) machine=alpha ;;
|
|
esac
|
|
;;
|
|
|
|
@@ -2224,7 +2225,7 @@
|
|
decosf* | linux* | irix*) dash_r="-rpath " ;;
|
|
*)
|
|
dash_r=""
|
|
- for try_dash_r in "-R" "-R " "-rpath "; do
|
|
+ for try_dash_r in "-Wl,-R" "-R" "-R " "-rpath "; do
|
|
xe_check_libs="${try_dash_r}/no/such/file-or-directory"
|
|
XE_PROTECT_LINKER_FLAGS(xe_check_libs)
|
|
AC_TRY_LINK(, , dash_r="$try_dash_r")
|
|
@@ -4320,6 +4321,9 @@
|
|
eval "with_${feature}=no"
|
|
done
|
|
fi dnl with_tty
|
|
+
|
|
+AC_CHECK_LIB(ossaudio, main, LIBOSSAUDIO=-lossaudio)
|
|
+AC_SUBST(LIBOSSAUDIO)
|
|
|
|
dnl Do we need event-unixoid.o ?
|
|
dnl This is needed for X, or for TTY, or for MSWIN w/Cygwin select()
|