pkgsrc/editors/elvis/patches/patch-ab
jlam 7f4de2f919 Restructure the following packages:
editors/elvis
	editors/elvis-x11

The latter is now just editors/elvis built with a specific set of
options.  Changes include:

+ Add options.mk that supports a new "x11" option.

+ Remove Makefile.common and move all logic into elvis/Makefile and
  elvis/options.mk.

+ Rename PLIST.common to PLIST as there are no PLIST differences
  between elvis and elvis-x11.

+ Modify patch-ab to add a --sysconfdir option to the configure script
  and fix the parsing of --with-x* options so that --with-xft isn't
  ignored.

+ Modify patch-ac to handle SYSCONFDIR in Makefile.in passed in from the
  configure script.

+ Remove the unnecessary substitution for PKG_SYSCONFDIR now that the
  configure script and Makefile.in directly support --sysconfdir.

+ Include termcap.buildlink3.mk to properly deal with termcap/curses
  issues (elvis needs termcap).

+ Add full DESTDIR support.

+ Set HOMEPAGE to the correct URL.

+ Bump the PKGREVISION for elvis and elvis-x11 to 6.  Both packages
  now track and use the same PKGREVISION number.
2008-04-22 16:23:57 +00:00

108 lines
3.4 KiB
Text

$NetBSD: patch-ab,v 1.3 2008/04/22 16:23:57 jlam Exp $
--- configure.orig 2003-10-20 22:32:25.000000000 -0400
+++ configure
@@ -27,6 +27,7 @@ GUI_GNOME=bug
# --bindir=DIR where to install the executables
# --datadir=DIR where to install the supporting data files
# --docdir=DIR where to install the :help files & other docs
+# --sysconfdir=DIR where to install the configuration files
# --prefix=DIR like --bindir=DIR/bin --datadir=DIR/lib/elvis
# --ioctl=VARIETY type of tty ioctl to use: termios, termio, sgtty
# --verbose explain each decision
@@ -66,6 +67,7 @@ PREFIX=/usr
BINDIR='$(PREFIX)/bin'
DATADIR='$(PREFIX)/share/elvis/'
DOCDIR='$(PREFIX)/share/elvis/doc/'
+SYSCONFDIR='/etc/elvis'
SYS=""
DEFAULT_CC="cc -O"
IOCTL=""
@@ -130,6 +132,7 @@ usage()
echo " --x-libraries=DIR add DIR to path for X-windows libraries"
echo " --bindir=DIR where to install the executables"
echo " --datadir=DIR where to install the supporting data files"
+ echo " --sysconfdir=DIR where to install the configuration files"
echo " --prefix=DIR like --bindir=DIR/bin --datadir=DIR/share/elvis"
echo " --libs=STRING non-X11 part of the LIBS= string in Makefile"
echo " --ioctl=VARIETY type of tty ioctl to use: termios, termio, or sgtty"
@@ -157,14 +160,6 @@ do
GUI_GNOME=define
args="$args --with-gnome"
;;
- --with-x=no|--without-x)
- GUI_X11=undef
- args="$args --with-x=no"
- ;;
- --with-x*)
- GUI_X11=define
- args="$args --with-x"
- ;;
--with-xft=no|--without-xft)
FEATURE_XFT=undef
args="$args --with-xft=no"
@@ -173,6 +168,14 @@ do
FEATURE_XFT=define
args="$args --with-xft"
;;
+ --with-x=no|--without-x)
+ GUI_X11=undef
+ args="$args --with-x=no"
+ ;;
+ --with-x*)
+ GUI_X11=define
+ args="$args --with-x"
+ ;;
--with-gcc=no|--without-gcc)
gnu=n
forcegcc=n
@@ -203,6 +206,10 @@ do
DOCDIR=`echo "$i"|sed 's/^--docdir=//'`
args="$args $i"
;;
+ --sysconfdir=*)
+ SYSCONFDIR=`echo "$i"|sed 's/^--sysconfdir=//'`
+ args="$args $i"
+ ;;
--prefix=*)
PREFIX=`echo "$i"|sed 's/^--prefix=//'`
args="$args $i"
@@ -886,6 +893,7 @@ echo "Compiler: $CC"
echo "Bin dir: "`echo "$BINDIR" |sed s,'$(PREFIX)',"$PREFIX",`
echo "Data dir: "`echo "$DATADIR"|sed s,'$(PREFIX)',"$PREFIX",`
echo "Doc dir: "`echo "$DOCDIR" |sed s,'$(PREFIX)',"$PREFIX",`
+echo "Conf dir: "`echo "$SYSCONFDIR"|sed s,'$(PREFIX)',"$PREFIX",`
echo "Man dir: "`sh instman.sh -d -p"${PREFIX}"`
[ "$WHY" ] || echo "To see details, run \"configure --verbose\""
@@ -905,11 +913,8 @@ if [ "$GUI_X11" = "define" ]
then
case "$FEATURE_XFT" in
define)
- xft="-lXft "
- if [ -d /usr/include/freetype2 ]
- then
- CC="$CC -I/usr/include/freetype2"
- fi
+ xft="`pkg-config --libs freetype2 xft` "
+ CC="$CC `pkg-config --cflags freetype2 xft`"
;;
*)
xft=""
@@ -950,7 +955,7 @@ esac
# Generate the "config.h" file
-ELVISPATH=`echo "~/.elvis:/etc/elvis:$DATADIR:$DOCDIR" | sed s,'$(DATADIR)',"$DATADIR",g\;s,'$(PREFIX)',"$PREFIX",g`
+ELVISPATH=`echo "~/.elvis:$SYSCONFDIR:$DATADIR:$DOCDIR" | sed s,'$(DATADIR)',"$DATADIR",g\;s,'$(PREFIX)',"$PREFIX",g`
cat >config.h <<eof-config
/* config.h */
@@ -1200,6 +1205,7 @@ s!^PREFIX=.*!PREFIX=$PREFIX!
s!^BINDIR=.*!BINDIR=$BINDIR!
s!^DATADIR=.*!DATADIR=$DATADIR!
s!^DOCDIR=.*!DOCDIR=$DOCDIR!
+s!^SYSCONFDIR=.*!SYSCONFDIR=$SYSCONFDIR!
eof-all
if [ -d /usr/local/X11/include ]
then