pkgsrc/emulators/x48/patches/patch-configure.ac
he 4d490f0667 Update x48 from version 0.4.1 to 0.6.4.
Pkgsrc changes;
 * HOMEPAGE & distribution site moved.
 * HP has released the ROMs, and copies of these are now automatically
   installed.
 * I could not get the X11 shm option to work (native X11, NetBSD 6.1/i386),
   so it is disabled in the Makefile.
 * Patch with updated pty handling code, borrowing some from FreeBSD's
   package here.

Upstream changes:
2011-08-08 "G. Allen Morris III" <gam3@gam3.net> release 0.6.4
  * Default to throttling speed only when key-pressed
  * Add throttle switch for speed emulation
  * Fix buffer overflow bug
  * release keys on loss of focus
  * typo in access_time adjust

2010-02-01 "G. Allen Morris III" <gam3@gam3.net> release 0.6.3
  * made updates to x48.spec
  * put debian directory in dist file
  * install X48 app data in correct place
    using pkg-config appdefaultdir xt
  * removed more debugging messages
  * added 'netbook' look for small/short screens
    use +netbook on the command line

2010-01-30 "G. Allen Morris III" <gam3@gam3.net> release 0.6.2
  * remove setlocal code that was causing a bug.
  * removed some debugging code.

2009-06-31 "G. Allen Morris III" <gam3@gam3.net> release 0.6.1
  * Fix to XShm to solve the 'LCD' Scramble problem.

2006-04-20 "G. Allen Morris III" <gam3@gam3.net>
  * Added simple paste feature
  * Repaired debugger non-readline input
  * Changed from building with Imakefile to using GNU autoconfig

2005-03-20 "G. Allen Morris III" <gam3@gam3.net>
  * added equal key for + and Meta Keys for Alpha
  * applied a different fix for the arrow repeat key bug
  * fixed a bug in the timer one logic.  The cursor now flashes on input.

2005-03-20 "G. Allen Morris III" <gam3@gam3.net>
  * added patch [000390] time.h compile bug
  * added patch [000391] Arrow key repeat patch
  * added ChangeLog file

2005-03-18 "G. Allen Morris III" <gam3@gam3.net>
  * starting from x48 0.4.0.
2013-07-08 08:37:10 +00:00

26 lines
751 B
Text

$NetBSD: patch-configure.ac,v 1.1 2013/07/08 08:37:10 he Exp $
Add some tests for various PTY- and TTY-related functions.
--- configure.ac.orig 2011-11-15 03:03:40.000000000 +0000
+++ configure.ac
@@ -79,6 +79,19 @@ fi
# Checks for libraries.
AC_CHECK_LIB([GL], [XCloseDisplay])
+AC_SEARCH_LIBS([grantpt], [c], [
+ AC_DEFINE([HAVE_GRANTPT], 1, [Has grantpt() function])
+])
+AC_SEARCH_LIBS([ptsname_r], [c], [
+ AC_DEFINE([HAVE_PTSNAME_R], 1, [Has ptsname_r() function])
+])
+AC_SEARCH_LIBS([cfsetspeed], [c], [
+ AC_DEFINE([HAVE_CFSETSPEED], 1, [Has cfsetspeed() function])
+])
+AC_SEARCH_LIBS([openpty], [util], [
+ AC_DEFINE([HAVE_OPENPTY], 1, [Has openpty() function])
+ LIBS=-lutil ${LIBS}
+])
# Checks for header files.
AC_HEADER_STDC