717d3eec39
"libtcmgui" instead of "libgui". emulators/gpsim installs a libgui which causes problems. There may be conflicts with the other libs (libglobal, libtable, etc). To be safe, rename them all similarly. Get rid of the terrible configure script. It saved a few patches, but isn't worth the ugliness.
26 lines
596 B
Text
26 lines
596 B
Text
$NetBSD: patch-bd,v 1.1 2001/05/10 23:35:28 jtb Exp $
|
|
|
|
--- ui/Makefile.orig Wed Dec 20 13:32:52 2000
|
|
+++ ui/Makefile
|
|
@@ -49,15 +49,13 @@
|
|
|
|
MAIN = main.o
|
|
|
|
-libgui.a: $(OBJECTS) $(MAIN)
|
|
- $(AR) $@ $(OBJECTS) $(MAIN)
|
|
- chmod a+rx $@
|
|
- $(MV) $@ $(LIB_DIR)
|
|
+libtcmgui.a: $(OBJECTS) $(MAIN)
|
|
+ $(AR) cr $@ $(OBJECTS) $(MAIN)
|
|
+ $(MV) -f $@ $(LIB_DIR)
|
|
|
|
-libguix.a: $(OBJECTS)
|
|
- ar cr $@ $(OBJECTS)
|
|
- chmod a+rx $@
|
|
- $(MV) $@ $(LIB_DIR)
|
|
+libtcmguix.a: $(OBJECTS)
|
|
+ $(AR) cr $@ $(OBJECTS)
|
|
+ $(MV) -f $@ $(LIB_DIR)
|
|
|
|
libgui.so: $(OBJECTS) $(MAIN)
|
|
$(CC) $(CFLAGS) $(SHAREDFLAG) $(OBJECTS) $(MAIN) -o $@
|