Eliom is an OCaml library for the webserver Ocsigen that allows for the creation of dynamic webpages. In this way, a website is not written as a separate set of pages, but as one integral OCaml module.
15 lines
521 B
Text
15 lines
521 B
Text
$NetBSD: patch-src_client_Makefile,v 1.1 2012/08/12 17:47:43 wiz Exp $
|
|
|
|
install library stub with proper permissions
|
|
--- src/client/Makefile.orig 2012-06-11 12:46:54.000000000 +0000
|
|
+++ src/client/Makefile
|
|
@@ -97,7 +97,8 @@ odoc: ${DOC:.mli=.odoc}
|
|
|
|
install: ${PREDEP}
|
|
${INSTALL} -m 755 -d ${CLIENTDIR}
|
|
- ${INSTALL} -m 644 ${INTF} ${IMPL} ${STUBS} ${DOC} ${CLIENTDIR}
|
|
+ ${INSTALL} -m 644 ${INTF} ${IMPL} ${DOC} ${STUBS} ${CLIENTDIR}
|
|
+ ${BSD_INSTALL_LIB} ${EXEC_STUBS} ${CLIENTDIR}
|
|
|
|
uninstall:
|
|
-rm -fr ${CLIENTDIR}
|