47753fccb3
changes include: - ups info moved to ups.conf instead of upsd.conf - unified driver control between ups drivers - upsmon doesn't run as root by default any more; most of the work is done by an unprivileged child, with a parent only accepting shutdown messages - more model support: - AEG Proect S. - aeg - SMS Ltda (Brazillian) - sms - SOLA 620 - bestups - Ever UPS - everups - various other improvements and bugfixes see http://www.exploits.org/nut/release/new-0.45.1.txt for more details)
29 lines
1.2 KiB
Text
29 lines
1.2 KiB
Text
$NetBSD: patch-ad,v 1.2 2001/09/28 04:37:27 lukem Exp $
|
|
|
|
--- configure.in.orig Tue Jun 12 07:47:56 2001
|
|
+++ configure.in Fri Sep 28 10:41:01 2001
|
|
@@ -396,13 +396,17 @@
|
|
dnl | let's test it for sanity before proceeding. It's better to |
|
|
dnl | catch them here rather than in the program itself at runtime. |
|
|
|
|
-grep "^$RUN_AS_GROUP:" /etc/group >/dev/null 2>/dev/null
|
|
-if (test "$?" = "1")
|
|
-then
|
|
- # not found, fatal error
|
|
- AC_MSG_WARN($RUN_AS_GROUP not found in /etc/group!)
|
|
- AC_MSG_WARN(You might want to rerun configure using --with-group and another group name.)
|
|
-fi
|
|
+dnl | NetBSD's pkgsrc setup creates the user and group AFTER the build
|
|
+dnl | and BEFORE install. This gives the configure and build a chance
|
|
+dnl | to fail before modifying the group and passwd files.
|
|
+dnl
|
|
+dnl grep "^$RUN_AS_GROUP:" /etc/group >/dev/null 2>/dev/null
|
|
+dnl if (test "$?" = "1")
|
|
+dnl then
|
|
+dnl # not found, fatal error
|
|
+dnl AC_MSG_WARN($RUN_AS_GROUP not found in /etc/group!)
|
|
+dnl AC_MSG_WARN(You might want to rerun configure using --with-group and another group name.)
|
|
+dnl fi
|
|
|
|
dnl | All done with group tests. |
|
|
dnl +------------------------------------------------------------------+
|