pkgsrc/graphics/graphviz/patches/patch-ae
seb 20c6cc2031 Update to version 1.12
Package changes:
	- bl3ify
	- provide a buildlinl3.mk
	- no more conflicting with package coreutils

Changes in graphviz since last packaged version:

March 1, 2004
- release 1.12
- general
  - rename bcc -> bcomps to avoid name conflict with "Bruce's C Compiler"
    on Redhat distributions.
  - all build without X11 (fix problem in lefty tree)
  - remove from distribution:
    dag, fdp, geo, grid, incr, shape, tcldgr, tcldgl
- dotneato
  - fix "brown-bag" problem resulting in PNG and JPEG errors on RH8 and RH9.

February 23, 2004
- release 1.11
- general
  - fix windows builds
  - add tool "bcc" to distribution
- dotneato
  - add -Gviewport="X,Y,Z,x,y"  where XY are the dimensions of a viewport
    in device coordinates (pixels), Z is a zooming factor, x,y is the
    location of the center of the viewport in graph coordinates.
    Supported in bitmap and imagemap outputs only.
  - fix memory leak in gd/gdft.c
  - clean up calculation of whitespace around labels
- dotty, lefty
  - fix for bug #400

December 23, 2003
	- added dijkstra (single source distance) filter

September 10, 2003
- general
  - removed CVS directories from .tar.gz distributions
  - add "config" directory to contain some of the autoconf clutter
  - only remove flex products with "make maintainer-clean" to
    avoid trying to regenerate them after "make distclean"
    basically this is to avoid the broken flex on Debian.
  - suppress complaints from ./configure about config.rpath
  - doc/build.html updated with notes about Windows builds
  - build fixes for Forte 6sp2 compiler on Sun -xarch=v9a (64bit)
  - build fixes for OpenBSD
  - improved configure testing for Tcl/Tk
  - various bug fixes, internal restructuring, etc
- dotneato
  - fix problem with extra escape chars in .fig output
  - support for "setlinewidth" in -Tfig
  - improved splines in -Tfig
  - add manpage for dotneato-config
  - neato: add defaultdist graph attribute to set distance
    between components
  - first cut at html table formatter add. not ready for use yet
    as the syntax is going to change some more.
- tools
  - renamed "colorize" to "gvcolor" to avoid conflict on Debian
  - renamed "gpr" to "gvpr" to avoid conflict on Debian
  - add fflush() to acyclic, ccomps, gvcolor, tred, dot2gxl
    to try to fix truncated output when used in php or perl cgi scripts
2004-04-17 16:56:10 +00:00

39 lines
1.2 KiB
Text

$NetBSD: patch-ae,v 1.7 2004/04/17 16:56:10 seb Exp $
--- gdtclft/Makefile.in.orig 2004-04-17 13:41:29.000000000 +0000
+++ gdtclft/Makefile.in
@@ -104,7 +104,6 @@ SOCKET_LIBS = @SOCKET_LIBS@
SORT = @SORT@
STRIP = @STRIP@
TCLINT_INCLUDES = @TCLINT_INCLUDES@
-TCLSH = @TCLSH@
TCLSH_EXEC_PREFIX = @TCLSH_EXEC_PREFIX@
TCL_BUILD_LIB_SPEC = @TCL_BUILD_LIB_SPEC@
TCL_BUILD_STUB_LIB_PATH = @TCL_BUILD_STUB_LIB_PATH@
@@ -181,7 +180,6 @@ TK_XINCLUDES = @TK_XINCLUDES@
TK_XLIBSW = @TK_XLIBSW@
TOP_DIR = @TOP_DIR@
VERSION = @VERSION@
-WISH = @WISH@
XAW_INCLUDES = @XAW_INCLUDES@
XAW_LIBS = @XAW_LIBS@
XPM_INCLUDES = @XPM_INCLUDES@
@@ -218,7 +216,7 @@ libgdtclft_la_SOURCES = gdtclft.c
libgdtclft_la_LIBADD = \
$(top_builddir)/tclhandle/libtclhandle.la \
$(top_builddir)/gd/libgdconvenience.la \
- $(top_builddir)/tclstubs/libtclstubs.la
+ ${TCL_STUB_LIB_SPEC}
CLEANFILES = pkgIndex.tcl
@@ -232,8 +230,7 @@ LTLIBRARIES = $(pkglib_LTLIBRARIES)
libgdtclft_la_LDFLAGS =
libgdtclft_la_DEPENDENCIES = $(top_builddir)/tclhandle/libtclhandle.la \
- $(top_builddir)/gd/libgdconvenience.la \
- $(top_builddir)/tclstubs/libtclstubs.la
+ $(top_builddir)/gd/libgdconvenience.la
am_libgdtclft_la_OBJECTS = gdtclft.lo
libgdtclft_la_OBJECTS = $(am_libgdtclft_la_OBJECTS)