Fixed ldapsearch to explicitly flush its buffer (ITS-8118) Fixed libldap async connections (ITS-8090) Fixed libldap double free of request during abandon (ITS-7967) Fixed libldap error string for LDAP_X_CONNECTING (ITS-8093) Fixed libldap segfault in ldap_sync_initialize (ITS-8001) Fixed libldap ldif-wrap off by one error (ITS-8003) Fixed libldap handling of TLS in async mode (ITS-8022) Fixed libldap null pointer dereference (ITS-8028) Fixed libldap mutex handling with LDAP_OPT_SESSION_REFCNT (ITS-8050) Fixed slapd slapadd config db import of minimal frontend entry (ITS-8150) Fixed slapd slapadd onetime leak with -w (ITS-8014) Fixed slapd sasl auxprop crash with invalid config (ITS-8092) Fixed slapd syncrepl delta-mmr issue with overlays and slapd.conf (ITS-7976) Fixed slapd syncrepl mutex for cookie state (ITS-7968) Fixed slapd syncrepl memory leaks (ITS-8035) Fixed slapd syncrepl to free presentlist at end of refresh mode (ITS-8038) Fixed slapd syncrepl to streamline presentlist (ITS-8042) Fixed slapd syncrepl concurrency when CHECK_CSN is enabled (ITS-8120) Fixed slapd rootdn checks for hidden backends (ITS-8108) Fixed slapd segfault when using matched values control (ITS-8046) Fixed slapd-ldap reconnection behavior on remote failure (ITS-8142) Fixed slapd-mdb minor case typo (ITS-8049) Fixed slapd-mdb one-level search (ITS-7975) Fixed slapd-mdb heap corruption (ITS-7965) Fixed slapd-mdb crash after deleting in-use schema (ITS-7995) Fixed slapd-mdb minor code cleanup (ITS-8011) Fixed slapd-mdb to return errors when using incorrect env flags (ITS-8016) Fixed slapd-mdb to correctly update search candidates (ITS-8036, ITS-7904) Fixed slapd-mdb when there were more than 65535 aliases in scope (ITS-8103) Fixed slapd-mdb alias deref when objectClass is not indexed (ITS-8146) Fixed slapd-meta TLS initialization with ldaps URIs (ITS-8022) Fixed slapd-meta to have better error logging (ITS-8131) Fixed slapd-perl conversion to cn=config (ITS-8105) Fixed slapd-sql autocommit config variable (ITS-8129,ITS-6613) Fixed slapo-collect segfault (ITS-7797) Fixed slapo-constraint with 0 count constraint (ITS-7780,ITS-7781) Fixed slapo-deref with empty attribute list (ITS-8027) Fixed slapo-memberof to correctly reject invalid members (ITS-8107) Fixed slapo-sock result parser for CONTINUE (ITS-8048) Fixed slapo-syncprov synprov_matchops usage of test_filter (ITS-8013) Fixed slapo-syncprov segfault on disconnect/abandon (ITS-5452,ITS-8012) Fixed slapo-syncprov memory leak (ITS-8039) Fixed slapo-syncprov segfault on disconnect/abandon (ITS-8043) Fixed slapo-syncprov deadlock when autogroup is in use (ITS-8063) Fixed slapo-syncprov potential loss of changes when under load (ITS-8081) Fixed slapo-unique enforcement of uniqueness with manageDSAit control (ITS-8057) Build Environment Fixed libdb detection with gcc 5.x (ITS-8056) Fixed ftello reference for Win32 (ITS-8127) Enhanced contrib modules build paths (ITS-7782) Fixed contrib/autogroup internal operation identity (ITS-8006) Fixed contrib/autogroup to skip internal ops with accesslog (ITS-8065) Fixed contrib/passwd/sha2 compiler warning (ITS-8000) Fixed contrib/noopsrch compiler warning (ITS-7998) Fixed contrib/dupent compiler warnings (ITS-7997) Test suite: Added vrFilter test (ITS-8046) Contrib Added pbkdf2 sha256 and sha512 schemes (ITS-7977) Fixed autogroup modification callback responses (ITS-6970) Fixed nssov compare with usergroup (ITS-8079) Fixed nssov password change behavior (ITS-8080) Fixed nssov updated to 0.9.4 (ITS-8097) Documentation Added ldap_get_option(3) LDAP_FEATURE_INFO_VERSION information (ITS-8032) Added ldap_get_option(3) LDAP_OPT_API_INFO_VERSION information (ITS-8032) Fixed slapd-config(5), slapd.conf(5) tls_cipher_suite option (ITS-8099) Fixed slapd-meta(5), slapd-ldap(5) tls_cipher_suite option (ITS-8099) Fixed slapd-meta(5) fix minor typo (ITS-7769)
30 lines
1 KiB
Text
30 lines
1 KiB
Text
$NetBSD: patch-da,v 1.8 2015/07/17 14:49:05 adam Exp $
|
|
|
|
--- contrib/slapd-modules/smbk5pwd/Makefile.orig 2015-06-21 00:19:58.000000000 +0000
|
|
+++ contrib/slapd-modules/smbk5pwd/Makefile
|
|
@@ -15,8 +15,7 @@
|
|
LDAP_SRC = ../../..
|
|
LDAP_BUILD = $(LDAP_SRC)
|
|
LDAP_INC = -I$(LDAP_BUILD)/include -I$(LDAP_SRC)/include -I$(LDAP_SRC)/servers/slapd
|
|
-LDAP_LIB = $(LDAP_BUILD)/libraries/libldap_r/libldap_r.la \
|
|
- $(LDAP_BUILD)/libraries/liblber/liblber.la
|
|
+LDAP_LIB = -lldap_r -llber
|
|
|
|
SSL_INC =
|
|
SSL_LIB = -lcrypto
|
|
@@ -25,12 +24,10 @@ HEIMDAL_INC = -I/usr/heimdal/include
|
|
HEIMDAL_LIB = -L/usr/heimdal/lib -lkrb5 -lkadm5srv
|
|
|
|
LIBTOOL = $(LDAP_BUILD)/libtool
|
|
-CC = gcc
|
|
-OPT = -g -O2 -Wall
|
|
+OPT = ${CFLAGS} ${CPPFLAGS}
|
|
# Omit DO_KRB5, DO_SAMBA or DO_SHADOW if you don't want to support it.
|
|
-DEFS = -DDO_KRB5 -DDO_SAMBA -DDO_SHADOW
|
|
-INCS = $(LDAP_INC) $(HEIMDAL_INC) $(SSL_INC)
|
|
-LIBS = $(LDAP_LIB) $(HEIMDAL_LIB) $(SSL_LIB)
|
|
+INCS = $(LDAP_INC) $(SSL_INC)
|
|
+LIBS = $(LDAP_LIB) $(SSL_LIB) ${EXTRA_LIBS}
|
|
|
|
PROGRAMS = smbk5pwd.la
|
|
LTVER = 0:0:0
|