c6151df67b
Prompted by Nicolas Joly in private mail. 1.10.4 - 01 Sept 2016 ------ - Fix assembler support for MIPS - Improve memory handling for temp buffers in collectives - Fix [all]reduce with non-zero lower bound datatypes Thanks Hristo Iliev for the report - Fix non-standard ddt handling. Thanks Yuki Matsumoto for the report - Various libnbc fixes. Thanks Yuki Matsumoto for the report - Fix typos in request RMA bindings for Fortran. Thanks to @alazzaro and @vondele for the assist - Various bug fixes and enhancements to collective support - Fix predefined types mapping in hcoll - Revive the coll/sync component to resolve unexpected message issues during tight loops across collectives - Fix typo in wrapper compiler for Fortran static builds 1.10.3 - 15 June 2016 ------ - Fix zero-length datatypes. Thanks to Wei-keng Liao for reporting the issue. - Minor manpage cleanups - Implement atomic support in OSHMEM/UCX - Fix support of MPI_COMBINER_RESIZED. Thanks to James Ramsey for the report - Fix computation of #cpus when --use-hwthread-cpus is used - Add entry points for Allgatherv, iAllgatherv, Reduce, and iReduce for the HCOLL library - Fix an HCOLL integration bug that could signal completion of request while still being worked - Fix computation of cores when SMT is enabled. Thanks to Ben Menadue for the report - Various USNIC fixes - Create a datafile in the per-proc directory in order to make it unique per communicator. Thanks to Peter Wind for the report - Fix zero-size malloc in one-sided pt-to-pt code. Thanks to Lisandro Dalcin for the report - Fix MPI_Get_address when passed MPI_BOTTOM to not return an error. Thanks to Lisandro Dalcin for the report - Fix MPI_TYPE_SET_ATTR with NULL value. Thanks to Lisandro Dalcin for the report - Fix various Fortran08 binding issues - Fix memchecker no-data case. Thanks to Clinton Stimpson for the report - Fix CUDA support under OS-X - Fix various OFI/MTL integration issues - Add MPI_T man pages - Fix one-sided pt-to-pt issue by preventing communication from happening before a target enters a fence, even in the no-precede case - Fix a bug that disabled Totalview for MPMD use-case - Correctly support MPI_UNWEIGHTED in topo-graph-neighbors. Thanks to Jun Kudo for the report - Fix singleton operations under SLURM when PMI2 is enabled - Do not use MPI_IN_PLACE in neighborhood collectives for non-blocking collectives (libnbc). Thanks to Jun Kudo for the report - Silence autogen deprecation warnings for newer versions of Perl - Do not return MPI_ERR_PENDING from collectives - Use type int* for MPI_WIN_DISP_UNIT, MPI_WIN_CREATE_FLAVOR, and MPI_WIN_MODEL. Thanks to Alastair McKinstry for the report - Fix register_datarep stub function in IO/OMPIO. Thanks to Eric Chamberland for the report - Fix a bus error on MPI_WIN_[POST,START] in the shared memory one-sided component - Add several missing MPI_WIN_FLAVOR constants to the Fortran support - Enable connecting processes from different subnets using the openib BTL - Fix bug in basic/barrier algorithm in OSHMEM - Correct process binding for the --map-by node case - Include support for subnet-to-subnet routing over InfiniBand networks - Fix usnic resource check - AUTHORS: Fix an errant reference to Subversion IDs - Fix affinity for MPMD jobs running under LSF - Fix many Fortran binding bugs - Fix `MPI_IN_PLACE`-related bugs - Fix PSM/PSM2 support for singleton operations - Ensure MPI transports continue to progress during RTE barriers - Update HWLOC to 1.9.1 end-of-series - Fix a bug in the Java command line parser when the -Djava.library.path options was given by the user - Update the MTL/OFI provider selection behavior - Add support for clock_gettime on Linux. - Correctly detect and configure for Solaris Studio 12.5 beta compilers - Correctly compute #slots when -host is used for MPMD case - Fix a bug in the hcoll collectives due to an uninitialized field - Do not set a binding policy when oversubscribing a node - Fix hang in intercommunicator operations when oversubscribed - Speed up process termination during MPI_Abort - Disable backtrace support by default in the PSM/PSM2 libraries to prevent unintentional conflicting behavior. 1.10.2: 26 Jan 2016 ------------------- ********************************************************************** * OSHMEM is now 1.2 compliant ********************************************************************** - Fix NBC_Copy for legitimate zero-size messages - Fix multiple bugs in OSHMEM - Correctly handle mpirun --host <user>@<ip-address> - Centralize two MCA params to avoid duplication between OMPI and OSHMEM layers: opal_abort_delay and opal_abort_print_stack - Add support for Fujitsu compilers - Add UCX support for OMPI and OSHMEM - Correctly handle oversubscription when not given directives to permit it. Thanks to @ammore1 for reporting it - Fix rpm spec file to not include the /usr directory - Add Intel HFI1 default parameters for the openib BTL - Resolve symbol conflicts in the PSM2 library - Add ability to empty the rgpusm cache when full if requested - Fix another libtool bug when -L requires a space between it and the path. Thanks to Eric Schnetter for the patch. - Add support for OSHMEM v1.2 APIs - Improve efficiency of oshmem_preconnect_all algorithm - Fix bug in buffered sends support - Fix double free in edge case of mpirun. Thanks to @jsharpe for the patch - Multiple one-sided support fixes - Fix integer overflow in the tuned "reduce" collective when using buffers larger than INT_MAX in size - Fix parse of user environment variables in mpirun. Thanks to Stefano Garzarella for the patch - Performance improvements in PSM2 support - Fix NBS iBarrier for inter-communicators - Fix bug in vader BTL during finalize - Improved configure support for Fortran compilers - Fix rank_file mapper to support default --slot-set. Thanks to Matt Thompson for reporting it - Update MPI_Testsome man page. Thanks to Eric Schnetter for the suggestion - Fix missing resize of the returned type for subarray and darray types. Thanks to Keith Bennett and Dan Garmann for reporting it - Fix Java support on OSX 10.11. Thanks to Alexander Daryin for reporting the problem - Fix some compilation issues on Solaris 11.2. Thanks to Paul Hargrove for his continued help in such areas
53 lines
2.3 KiB
Text
53 lines
2.3 KiB
Text
$NetBSD: patch-ai,v 1.6 2016/10/23 14:02:28 asau Exp $
|
|
|
|
--- orte/etc/Makefile.in.orig 2016-09-02 01:30:19.000000000 +0000
|
|
+++ orte/etc/Makefile.in
|
|
@@ -1515,6 +1515,7 @@ spml_ucx_LDFLAGS = @spml_ucx_LDFLAGS@
|
|
spml_ucx_LIBS = @spml_ucx_LIBS@
|
|
srcdir = @srcdir@
|
|
sysconfdir = @sysconfdir@
|
|
+sysconfexampledir = $(pkgdatadir)/examples
|
|
target = @target@
|
|
target_alias = @target_alias@
|
|
target_cpu = @target_cpu@
|
|
@@ -1731,19 +1732,19 @@ uninstall-am: uninstall-local
|
|
# details why the mkdir is in install-data-local.
|
|
|
|
install-data-local:
|
|
- $(MKDIR_P) $(DESTDIR)$(sysconfdir)
|
|
+ $(MKDIR_P) $(DESTDIR)$(sysconfexampledir)
|
|
@ p="$(orte_config_files)"; \
|
|
for file in $$p; do \
|
|
- if test -f $(DESTDIR)$(sysconfdir)/$$file; then \
|
|
+ if test -f $(DESTDIR)$(sysconfexampledir)/$$file; then \
|
|
echo "******************************* WARNING ************************************"; \
|
|
echo "*** Not installing new $$file over existing file in:"; \
|
|
- echo "*** $(DESTDIR)$(sysconfdir)/$$file"; \
|
|
+ echo "*** $(DESTDIR)$(sysconfexampledir)/$$file"; \
|
|
echo "******************************* WARNING ************************************"; \
|
|
else \
|
|
if test -f "$$file"; then d=; else d="$(srcdir)/"; fi; \
|
|
f="`echo $$file | sed -e 's|^.*/||'`"; \
|
|
- echo " $(INSTALL_DATA) $$d$$file $(DESTDIR)$(sysconfdir)/$$f"; \
|
|
- $(INSTALL_DATA) $$d$$file $(DESTDIR)$(sysconfdir)/$$f; \
|
|
+ echo " $(INSTALL_DATA) $$d$$file $(DESTDIR)$(sysconfexampledir)/$$f"; \
|
|
+ $(INSTALL_DATA) $$d$$file $(DESTDIR)$(sysconfexampledir)/$$f; \
|
|
fi; \
|
|
done
|
|
|
|
@@ -1754,11 +1755,11 @@ install-data-local:
|
|
uninstall-local:
|
|
@ p="$(orte_config_files)"; \
|
|
for file in $$p; do \
|
|
- if test -f "$(DESTDIR)$(sysconfdir)/$$file"; then \
|
|
+ if test -f "$(DESTDIR)$(sysconfexampledir)/$$file"; then \
|
|
if test -f "$$file"; then d=; else d="$(srcdir)/"; fi; \
|
|
- if diff "$(DESTDIR)$(sysconfdir)/$$file" "$$d$$file" > /dev/null 2>&1 ; then \
|
|
- echo "rm -f $(DESTDIR)$(sysconfdir)/$$file" ; \
|
|
- rm -f "$(DESTDIR)$(sysconfdir)/$$file" ; \
|
|
+ if diff "$(DESTDIR)$(sysconfexampledir)/$$file" "$$d$$file" > /dev/null 2>&1 ; then \
|
|
+ echo "rm -f $(DESTDIR)$(sysconfexampledir)/$$file" ; \
|
|
+ rm -f "$(DESTDIR)$(sysconfexampledir)/$$file" ; \
|
|
fi ; \
|
|
fi ; \
|
|
done
|