pkgsrc/audio/opus-tools/patches/patch-configure.ac
ryoon af276dd537 Update to 0.1.8
* opusenc required audio/flac

Changelog:
opus-tools 0.1.8
This release fixes a memory corruption bug with FLAC album art
handling.

opus-tools 0.1.7
This release has numerious build fixes, including updated Visual
Studio project files to match similar changes in the opus package.
Support encoding from FLAC files. Metadata tag support, including
album art. Use the new surround encoder API in opus 1.0.3. The
opusenc --uncoupled switch no longer works.
2014-01-02 14:52:10 +00:00

34 lines
998 B
Text

$NetBSD: patch-configure.ac,v 1.2 2014/01/02 14:52:10 ryoon Exp $
* Disable opusdec's direct audio output
--- configure.ac.orig 2013-12-06 02:31:11.000000000 +0000
+++ configure.ac
@@ -145,18 +145,18 @@ AS_IF([test "$HAVE_PKG_CONFIG" = "yes"],
])
dnl check for OSS
-HAVE_OSS=no
-AC_CHECK_HEADERS([sys/soundcard.h soundcard.h machine/soundcard.h],[
- HAVE_OSS=yes
- break
-])
+dnl HAVE_OSS=no
+dnl AC_CHECK_HEADERS([sys/soundcard.h soundcard.h machine/soundcard.h],[
+dnl HAVE_OSS=yes
+dnl break
+dnl ])
dnl check for sndio
-AC_CHECK_LIB([sndio], [sio_open])
+dnl AC_CHECK_LIB([sndio], [sio_open])
-if test "$HAVE_OSS" != "yes" && test "$ac_cv_lib_sndio_sio_open" != "yes"; then
- AC_MSG_WARN([Audio support not found -- no direct audio output in opusdec])
-fi
+dnl if test "$HAVE_OSS" != "yes" && test "$ac_cv_lib_sndio_sio_open" != "yes"; then
+dnl AC_MSG_WARN([Audio support not found -- no direct audio output in opusdec])
+dnl fi
dnl check for flac
AC_ARG_WITH([flac],