pkgsrc/converters/libiconv/patches/patch-ae
wiz 6eaa530983 Update to 1.11:
New in 1.11:
* The iconv program has new options --unicode-subst, --byte-subst,
  --widechar-subst that allow to specify substitutions for characters that
  cannot be converted.
* The iconv program now understands long options:
    long option    equivalent to
    --from-code    -f
    --to-code      -t
    --list         -l
    --silent       -s
* The CP936 converter is now different from the GBK converter: it has changed
  to include the Euro sign and private area characters. CP936 is no longer an
  alias of GBK.
* Updated GB18030 converter to include all private area characters.
* Updated CP950 converter to include the Euro sign and private area characters.
* Updated CP949 converter to include private area characters.
* Updated the BIG5-HKSCS converter. The old BIG5-HKSCS converter is renamed to
  BIG5-HKSCS:1999 and updated to Unicode 4. New converters BIG5-HKSCS:2001 and
  BIG5-HKSCS:2004 are added. BIG5-HKSCS is now an alias for BIG5-HKSCS:2004.
* Added a few irreversible mappings to the CP932 converter.
* Tidy up the list of symbols exported from libiconv (assumes gcc >= 4.0).
2007-03-20 00:44:52 +00:00

45 lines
1.9 KiB
Text

$NetBSD: patch-ae,v 1.6 2007/03/20 00:44:53 wiz Exp $
--- libcharset/lib/Makefile.in.orig 2006-07-14 13:18:55.000000000 +0000
+++ libcharset/lib/Makefile.in
@@ -9,7 +9,7 @@ srcdir = @srcdir@
prefix = @prefix@
local_prefix = /usr/local
exec_prefix = @exec_prefix@
-libdir = @libdir@
+libdir ?= @libdir@
# Programs used by "make":
CC = @CC@
@@ -79,13 +79,13 @@ ref-del.sed : $(srcdir)/ref-del.sin
# Installs the library and include files only. Typically called with only
# $(libdir) and $(includedir) - don't use $(prefix) and $(exec_prefix) here.
install-lib : all force
- $(mkinstalldirs) $(libdir)
- $(LIBTOOL_INSTALL) $(INSTALL_DATA) libcharset.la $(libdir)/libcharset.la
- test -f $(libdir)/charset.alias && orig=$(libdir)/charset.alias \
- || orig=charset.alias; \
- sed -f ref-add.sed $$orig > $(libdir)/t-charset.alias; \
- $(INSTALL_DATA) $(libdir)/t-charset.alias $(libdir)/charset.alias; \
- rm -f $(libdir)/t-charset.alias
+
+install-charset-alias : all force
+ $(mkinstalldirs) $(DESTDIR)$(libdir)
+# $(LIBTOOL_INSTALL) $(INSTALL) libcharset.la $(libdir)/libcharset.la
+ orig=charset.alias; \
+ sed -f ref-add.sed $$orig > t-charset.alias; \
+ $(INSTALL_DATA) t-charset.alias $(DESTDIR)$(libdir)/charset.alias; \
# The following is needed in order to install a simple file in $(libdir)
# which is shared with other installed packages. We use a list of referencing
@@ -96,7 +96,9 @@ install-lib : all force
install : all force
$(mkinstalldirs) $(DESTDIR)$(libdir)
- $(LIBTOOL_INSTALL) $(INSTALL_DATA) libcharset.la $(DESTDIR)$(libdir)/libcharset.la
+ $(LIBTOOL_INSTALL) $(INSTALL) libcharset.la $(DESTDIR)$(libdir)/libcharset.la
+
+install-charset-alias-unused:
if test -f $(DESTDIR)$(libdir)/charset.alias; then \
sed -f ref-add.sed $(DESTDIR)$(libdir)/charset.alias > $(DESTDIR)$(libdir)/t-charset.alias; \
$(INSTALL_DATA) $(DESTDIR)$(libdir)/t-charset.alias $(DESTDIR)$(libdir)/charset.alias; \