pkgsrc/converters/libiconv/patches/patch-af
wiz a53396f3de Update to 1.12:
New in libiconv-1.12-cp932.patch:
* Changed CP932 converter to use exact mapping table.
* Added WINDOWS-31J, csWINDOWS31J, SJIS-OPEN, SJIS-WIN as aliases for CP932.
* Added EUCJP-MS converter.
* Added EUC-JP-MS, EUCJP-OPEN, EUCJP-WIN as aliases for EUCJP-MS.

New in 1.12:
* The iconv program is now licensed under the GPL version 3, instead of the
  GPL version 2. The libiconv library continues to be licensed under LGPL.
* Added RK1048 converter.
* On AIX, an existing system libiconv no longer causes setlocale() to fail.
* Upgraded EUC-KR, JOHAB to include the Korean postal code sign.
2007-11-29 17:05:34 +00:00

21 lines
1.1 KiB
Text

$NetBSD: patch-af,v 1.3 2007/11/29 17:05:35 wiz Exp $
--- lib/Makefile.in.orig 2007-05-27 22:15:31.000000000 +0000
+++ lib/Makefile.in
@@ -118,14 +118,14 @@ libiconv.res : $(srcdir)/../windows/libi
# $(libdir) and $(includedir) - don't use $(prefix) and $(exec_prefix) here.
install-lib : all force
if [ ! -d $(libdir) ] ; then $(mkinstalldirs) $(libdir) ; fi
- $(LIBTOOL_INSTALL) $(INSTALL_DATA) libiconv.la $(libdir)/libiconv.la
+ $(LIBTOOL_INSTALL) $(INSTALL) libiconv.la $(libdir)/libiconv.la
# On AIX, libiconv.a must include the object files of /lib/libiconv.a,
# otherwise the setlocale() call fails when invoked from executables linked
# with -rpath $(libdir), even if linked without -liconv.
install : all force
if [ ! -d $(DESTDIR)$(libdir) ] ; then $(mkinstalldirs) $(DESTDIR)$(libdir) ; fi
- $(LIBTOOL_INSTALL) $(INSTALL_DATA) libiconv.la $(DESTDIR)$(libdir)/libiconv.la
+ $(LIBTOOL_INSTALL) $(INSTALL) libiconv.la $(DESTDIR)$(libdir)/libiconv.la
case "@host_os@" in \
aix*) (cd $(DESTDIR)$(libdir) && \
objects=`ar t libiconv.a`" "`ar t /lib/libiconv.a` && \