on all platforms supported by libtool. * Remove the unnecessary dependencies on glut and perl, and only use perl as a build dependency. * Use REPLACE_PERL instead of hand-crafted substitution code. Bump the PKGREVISION for graphics/OpenRM to 2. Due to the changed dependency graph, bump the PKGREVISION for packages that use the OpenRM libraries. In this case, games/genecys-client is the only one, so bump its PKGREVISION to 2.
13 lines
467 B
Text
13 lines
467 B
Text
$NetBSD: patch-ak,v 1.1 2005/06/23 04:02:48 jlam Exp $
|
|
|
|
--- rmi/Makefile.x11.orig 2004-01-16 23:09:05.000000000 -0500
|
|
+++ rmi/Makefile.x11
|
|
@@ -80,7 +80,7 @@ $(LIBDIR)/$(RMILIB): $(OBJECTS)
|
|
@if ([ -d $(LIBDIR) ]) then :; else (mkdir $(LIBDIR)); fi
|
|
@if (\rm -f $(LIBDIR)/$(RMILIB)) then :; fi
|
|
@$(MAKELIB) $(ARCHFLAGS) $(RMILIB) $(MAJOR) $(MINOR) $(OBJECTS)
|
|
- @mv $(RMILIB)* $(LIBDIR)
|
|
+ @cp $(RMILIB)* $(LIBDIR)
|
|
|
|
dep:
|
|
makedepend -Y -I../include *.c -f depend
|