12a671dbf1
the Google Summer of Code 2011 program. Congratulations, Dmitry! :-) This comes in the form of a new 'kqueue' build-time option. This should NOT be an option, but it is for two reasons: - I consider this still experimental for it to be enabled on everyone's machines, and the code is not "official". - The patch requires us to run automake/autoconf during the pre-configure stage, and I don't want to add these dependencies on the default package build. When these patches get integrated upstream, we can get rid of the option altogether. Also note that I had to backport some of our custom changes to Makefile.in files and some to configure to the original Makefile.am files and configure.ac. This is to prevent our custom patches from being lost during the automake/autoconf invocations we now do when 'kqueue' is enabled. Bump PKGREVISION to 1.
23 lines
828 B
Text
23 lines
828 B
Text
$NetBSD: patch-ck,v 1.1 2011/10/09 19:40:02 jmmv Exp $
|
|
|
|
--- glib/libcharset/Makefile.am.orig 2011-06-05 23:18:49.000000000 +0000
|
|
+++ glib/libcharset/Makefile.am
|
|
@@ -25,18 +25,6 @@ EXTRA_DIST += \
|
|
charset_alias = $(DESTDIR)$(libdir)/charset.alias
|
|
charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
|
|
install-exec-local: all-local
|
|
- $(mkinstalldirs) $(DESTDIR)$(libdir)
|
|
- if test -f $(charset_alias); then \
|
|
- sed -f ref-add.sed $(charset_alias) > $(charset_tmp) ; \
|
|
- $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
|
|
- rm -f $(charset_tmp) ; \
|
|
- else \
|
|
- if test @GLIBC21@ = no; then \
|
|
- sed -f ref-add.sed charset.alias > $(charset_tmp) ; \
|
|
- $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
|
|
- rm -f $(charset_tmp) ; \
|
|
- fi ; \
|
|
- fi
|
|
|
|
uninstall-local: all-local
|
|
if test -f $(charset_alias); then \
|