5e53b3f935
* GApplication: can now have a NULL application ID * g_clear_object: fix warnings when using it on C++ (due to lack of ability to implicitly cast void*) * GDBus: - add our own implementation of the message bus for use on Windows only - fix up a few bugs that use of this bus uncovered in GDBus - escape nonce files in dbus addressess (think 'c:\') - support initial underscores in dbus codegen namespace (for private) * Fix misdetection of GNUstep as Cocoa (for the MacOS GSettings backend) * make sure configure fails if AC_CHECK_ALIGNOF cannot detect the alignment * GAppInfo: overwrite the DISPLAY only if it is set in the launch context * glib/tests/date: force US locale running the GDateTime tests * GSocketControlMessage: Don't warn about unknown messages * Resources: - fix broken use of GVDB on big endian machines - set a 'display name' so that pretty file names appear in Gtk CSS warning messages * GMainContext: - block child sources when blocking the parent - introduce more testcases for child sources * Translations updates: Brazilian Portuguese French Galician Italian Lithuanian Polish Polish Serbian Simplified Chinese Spanish * Bug fixed: 619026 avoid warning in gutils.h when using gcc with -Wconversion 669260 Open/Save dialog hangs waiting for data with libsoup 671249 GApplication: Allow a null application_id? 672786 goa-daemon: action in notification doesn't work 673409 g_resource_lookup_data may return stale data pointer 674172 glib-2.32.1 misdetects GNUstep as Cocoa 674345 cssprovider: Make sure to print out file name in css warnings 674483 broken configure results when cross-compiling with gcc >= 4.5
19 lines
733 B
Text
19 lines
733 B
Text
$NetBSD: patch-cn,v 1.2 2012/05/01 18:45:53 adam Exp $
|
|
|
|
The mem-overflow test contains a declaration of an empty struct, which breaks
|
|
on at least SunPro cc, and presumably some other non-gcc compilers. Skip this
|
|
test for now, pending a better fix.
|
|
https://bugzilla.gnome.org/show_bug.cgi?id=641350
|
|
|
|
--- glib/tests/Makefile.am.orig 2011-06-05 23:18:49.000000000 +0000
|
|
+++ glib/tests/Makefile.am
|
|
@@ -76,9 +76,6 @@ hostutils_LDADD = $(progs_ldadd)
|
|
TEST_PROGS += gvariant
|
|
gvariant_LDADD = $(progs_ldadd)
|
|
|
|
-TEST_PROGS += mem-overflow
|
|
-mem_overflow_LDADD = $(progs_ldadd)
|
|
-
|
|
TEST_PROGS += utf8-performance
|
|
utf8_performance_SOURCES = utf8-performance.c
|
|
utf8_performance_LDADD = $(progs_ldadd)
|