2017-01-09 v1.6.1 "Long Tailed Duck" This release improves upon the VP9 encoder and speeds up the encoding and decoding processes. - Upgrading: This release is ABI compatible with 1.6.0. - Enhancements: Faster VP9 encoding and decoding. High bit depth builds now provide similar speed for 8 bit encode and decode for x86 targets. Other platforms and higher bit depth improvements are in progress. - Bug Fixes: A variety of fuzzing issues.
23 lines
723 B
Text
23 lines
723 B
Text
$NetBSD: patch-ab,v 1.8 2017/01/16 12:12:59 wiz Exp $
|
|
|
|
--- libs.mk.orig 2017-01-12 20:27:27.000000000 +0000
|
|
+++ libs.mk
|
|
@@ -172,7 +172,6 @@ INSTALL-LIBS-$(CONFIG_SHARED) += $(forea
|
|
endif
|
|
else
|
|
INSTALL-LIBS-$(CONFIG_STATIC) += $(LIBSUBDIR)/libvpx.a
|
|
-INSTALL-LIBS-$(CONFIG_DEBUG_LIBS) += $(LIBSUBDIR)/libvpx_g.a
|
|
endif
|
|
|
|
CODEC_SRCS=$(call enabled,CODEC_SRCS)
|
|
@@ -229,8 +228,8 @@ endif
|
|
else
|
|
LIBVPX_OBJS=$(call objs,$(CODEC_SRCS))
|
|
OBJS-yes += $(LIBVPX_OBJS)
|
|
-LIBS-$(if yes,$(CONFIG_STATIC)) += $(BUILD_PFX)libvpx.a $(BUILD_PFX)libvpx_g.a
|
|
-$(BUILD_PFX)libvpx_g.a: $(LIBVPX_OBJS)
|
|
+LIBS-$(if yes,$(CONFIG_STATIC)) += $(BUILD_PFX)libvpx.a
|
|
+$(BUILD_PFX)libvpx.a: $(LIBVPX_OBJS)
|
|
|
|
SO_VERSION_MAJOR := 4
|
|
SO_VERSION_MINOR := 1
|