pkgsrc/sysutils/py-psutil/patches/patch-setup.py
richard c3dc9c6ddc Update to 1.2.1, changelog follows:
1.2.1 - 2013-11-25
------------------

BUG FIXES

 * #348: [Windows XP] fixed "ImportError: DLL load failed" occurring on module
         import.
 * #425: [Solaris] crash on import due to failure at determining BOOT_TIME.
 * #443: [Linux] can't set CPU affinity on systems with more than 64 cores.


1.2.0 - 2013-11-20
------------------

ENHANCEMENTS

 * #439: assume os.getpid() if no argument is passed to psutil.Process
         constructor.
 * #440: new psutil.wait_procs() utility function which waits for multiple
         processes to terminate.

BUG FIXES

 * #348: [Windows XP/Vista] fixed "ImportError: DLL load failed" occurring on
         module import.


1.1.3 - 2013-11-07
------------------

BUG FIXES

 * #442: [Linux] psutil won't compile on certain version of Linux because of
         missing prlimit(2) syscall.
2013-12-07 21:25:23 +00:00

25 lines
620 B
Python

$NetBSD: patch-setup.py,v 1.3 2013/12/07 21:25:24 richard Exp $
Port to NetBSD.
--- setup.py.orig 2013-11-20 19:29:05.000000000 +0000
+++ setup.py
@@ -122,6 +122,18 @@ elif sys.platform.startswith("freebsd"):
libraries=["devstat"]),
posix_extension,
]
+# NetBSD
+elif sys.platform.startswith("netbsd"):
+ extensions = [Extension(
+ '_psutil_netbsd',
+ sources = [
+ 'psutil/_psutil_netbsd.c',
+ 'psutil/_psutil_common.c',
+ 'psutil/arch/netbsd/process_info.c'
+ ],
+ libraries=[]),
+ posix_extension,
+ ]
# Linux
elif sys.platform.startswith("linux"):
extensions = [Extension(