pkgsrc/lang/ocaml/patches/patch-bh
joerg eaa963de93 DragonFly needs the stublib PLIST fragment as well. Bump revision.
Fix another place where a ocaml script is installed with
BSD_INSTALL_PROGRAM, which doesn't work on DragonFly, since strip
bails out.
2005-12-22 14:37:17 +00:00

29 lines
1.3 KiB
Text

$NetBSD: patch-bh,v 1.2 2005/12/22 14:37:17 joerg Exp $
--- otherlibs/labltk/lib/Makefile.orig Fri Aug 9 02:46:30 2002
+++ otherlibs/labltk/lib/Makefile Thu Apr 22 10:34:37 2004
@@ -58,17 +58,13 @@
@echo 'exec $(INSTALLDIR)/$(LIBNAME)top$(EXE) -I $(INSTALLDIR) $$*' >> $@
install:
- if test -d $(INSTALLDIR); then : ; else mkdir $(INSTALLDIR); fi
- cp $(LIBNAME).cma $(LIBNAME)top$(EXE) $(INSTALLDIR)
- chmod 644 $(INSTALLDIR)/$(LIBNAME).cma
- chmod 755 $(INSTALLDIR)/$(LIBNAME)top$(EXE)
- @if test -d $(BINDIR); then : ; else mkdir $(BINDIR); fi
- cp $(LIBNAME) $(BINDIR)
- chmod 755 $(BINDIR)/$(LIBNAME)
+ if test -d $(INSTALLDIR); then : ; else ${BSD_INSTALL_DATA_DIR} $(INSTALLDIR); fi
+ ${BSD_INSTALL_DATA} $(LIBNAME).cma $(INSTALLDIR)
+ ${BSD_INSTALL_SCRIPT} $(LIBNAME)top$(EXE) $(INSTALLDIR)
+ @if test -d $(BINDIR); then : ; else ${BSD_INSTALL_PROGRAM_DIR} $(BINDIR); fi
+ ${BSD_INSTALL_SCRIPT} $(LIBNAME) $(BINDIR)
installopt:
- @if test -d $(INSTALLDIR); then : ; else mkdir $(INSTALLDIR); fi
- cp $(LIBNAME).cmxa $(LIBNAME).a $(INSTALLDIR)
+ @if test -d $(INSTALLDIR); then : ; else ${BSD_INSTALL_DATA_DIR} $(INSTALLDIR); fi
+ ${BSD_INSTALL_DATA} $(LIBNAME).cmxa $(LIBNAME).a $(INSTALLDIR)
cd $(INSTALLDIR); $(RANLIB) $(LIBNAME).a
- chmod 644 $(INSTALLDIR)/$(LIBNAME).cmxa
- chmod 644 $(INSTALLDIR)/$(LIBNAME).a