30 lines
1.5 KiB
Text
30 lines
1.5 KiB
Text
$NetBSD: patch-bo,v 1.2 2005/02/04 21:35:51 adrianp Exp $
|
|
|
|
--- otherlibs/systhreads/Makefile.orig 2003-08-21 14:52:07.000000000 +0100
|
|
+++ otherlibs/systhreads/Makefile 2004-10-12 22:21:43.000000000 +0100
|
|
@@ -70,18 +70,18 @@
|
|
rm -f $(GENFILES)
|
|
|
|
install:
|
|
- if test -f dllthreads.so; then cp dllthreads.so $(STUBLIBDIR)/dllthreads.so; fi
|
|
- cp libthreads.a $(LIBDIR)/libthreads.a
|
|
+ if test -f dllthreads.so; then ${BSD_INSTALL_DATA} dllthreads.so $(STUBLIBDIR)/dllthreads.so; fi
|
|
+ ${BSD_INSTALL_DATA} libthreads.a $(LIBDIR)/libthreads.a
|
|
cd $(LIBDIR); $(RANLIB) libthreads.a
|
|
- if test -d $(LIBDIR)/threads; then :; else mkdir $(LIBDIR)/threads; fi
|
|
- cp $(THREAD_OBJS:.cmo=.cmi) threads.cma $(LIBDIR)/threads
|
|
+ if test -d $(LIBDIR)/threads; then :; else ${BSD_INSTALL_DATA_DIR} $(LIBDIR)/threads; fi
|
|
+ ${BSD_INSTALL_DATA} $(THREAD_OBJS:.cmo=.cmi) threads.cma $(LIBDIR)/threads
|
|
rm -f $(LIBDIR)/threads/stdlib.cma
|
|
- cp thread.mli mutex.mli condition.mli event.mli threadUnix.mli $(LIBDIR)
|
|
+ ${BSD_INSTALL_DATA} thread.mli mutex.mli condition.mli event.mli threadUnix.mli $(LIBDIR)
|
|
|
|
installopt:
|
|
- cp libthreadsnat.a $(LIBDIR)/libthreadsnat.a
|
|
+ ${BSD_INSTALL_DATA} libthreadsnat.a $(LIBDIR)/libthreadsnat.a
|
|
cd $(LIBDIR); $(RANLIB) libthreadsnat.a
|
|
- cp $(THREAD_OBJS:.cmo=.cmx) threads.cmxa threads.a $(LIBDIR)/threads
|
|
+ ${BSD_INSTALL_DATA} $(THREAD_OBJS:.cmo=.cmx) threads.cmxa threads.a $(LIBDIR)/threads
|
|
cd $(LIBDIR)/threads; $(RANLIB) threads.a
|
|
|
|
.SUFFIXES: .ml .mli .cmo .cmi .cmx
|