2615325c03
* Fix build error with xft2 option and graphics/freetype-lib package is installed. Shoud be fix PR pkg/32656. * Refering PR pkg/38552 adpot some of patches. * Move PKG_OPTIONS related item to options.mk. * More pkgsrc clean up. * Try to reduce compile warnings. What's new in 1.13a? * m17n library support enhancement * MacOS support enhancement * add new environment variable MGPRC for the path of the .mgprc file. * add "psfont" directive to specify the font used by mgp2ps * add -g option for mgp2ps to allow users to adjust line distanc * add -zoomonclk option for newimage * allow to handle gif format images by default * many bug fixes Dedication Magicpoint 1.13a is dedicated to the memory of Dr. Jun-ichiro "itojun" Hagino, who was known for his enormous contribution to the Internet and the Open Source Software community. He was the developer of Magicpoint from its infancy. Magicpoint could not exist without his devoted work. What's new in 1.12a? * add %tsystem directive which might be more stable than %xsystem * add -rotate option for newimage * allow to use non-ASCI filename in slides (use -U to enable this feature) * many bug fixes
12 lines
477 B
Text
12 lines
477 B
Text
$NetBSD: patch-av,v 1.1 2008/09/10 13:32:48 taca Exp $
|
|
|
|
--- image/rotate.c.orig 2003-08-23 15:22:09.000000000 +0900
|
|
+++ image/rotate.c
|
|
@@ -40,6 +40,7 @@ int *new_pos; /* Destination bit posi
|
|
Image *rotate(simage, degrees, verbose)
|
|
Image *simage; /* Image to rotate */
|
|
int degrees; /* Number of degrees to rotate */
|
|
+int verbose;
|
|
{
|
|
char buf[BUFSIZ]; /* New title */
|
|
Image *image1; /* Source image */
|