pkgsrc/net/arla/patches/patch-af
wennmach 556282b81a Update arla to 0.34.1.
arla-0.34.1 contains a new `bos' program, improves handling of
write-back of mmaped pages after close, more stability, bug fixes,
and, most notably, contains updates to the *BSD code.
2000-08-15 16:08:23 +00:00

29 lines
1.1 KiB
Text

$NetBSD: patch-af,v 1.2 2000/08/15 16:08:25 wennmach Exp $
Do not attempt to install CellServDB, ThisCell, arla.conf. Only install
the default files and tell the user to customize them. This avoids PLIST
magic and assures that no customized files will be removed on pkg_delete.
--- conf/Makefile.in.orig Tue May 30 22:42:05 2000
+++ conf/Makefile.in Tue May 30 22:45:45 2000
@@ -26,19 +26,13 @@
for x in $$CONF_FILES; do \
echo $(INSTALL_DATA) $(srcdir)/$$x $(DESTDIR)$(sysconfdir)/$$x.default; \
$(INSTALL_DATA) $(srcdir)/$$x $(DESTDIR)$(sysconfdir)/$$x.default; \
- if test -f $(DESTDIR)$(sysconfdir)/$$x; then \
- echo "$@ will not overwrite $(DESTDIR)$(sysconfdir)/$$x"; \
- else \
- echo $(INSTALL_DATA) $(srcdir)/$$x $(DESTDIR)$(sysconfdir)/$$x; \
- $(INSTALL_DATA) $(srcdir)/$$x $(DESTDIR)$(sysconfdir)/$$x; \
- fi; \
done
+ > $(DESTDIR)$(sysconfdir)/SuidCells.default
uninstall:
CONF_FILES='$(CONF_FILES)'; \
for x in $$CONF_FILES; do \
rm -f $(DESTDIR)$(sysconfdir)/$$x.default; \
- rm -f $(DESTDIR)$(sysconfdir)/$$x; \
done
clean :