* Add patches to fix build problem with OpenSSL 1.0.0 beta and later. * Generase "-DUSE_SSL" instead of "-DSSL". Similar changes are CANNA and ZLIB. (In the case of ZLIB, it could be change to use HAVE_ZLIB_H.) * Split Makefile to use hacks.mk and options.mk. * And miscellaneous pkglint clean up. There should be no functional change and fix PR pkg/42452.
15 lines
281 B
Text
15 lines
281 B
Text
$NetBSD: patch-ah,v 1.1 2009/12/15 13:11:18 taca Exp $
|
|
|
|
* Change SSL to USE_SSL.
|
|
|
|
--- popxmit.c.orig 2003-05-17 05:17:45.000000000 +0900
|
|
+++ popxmit.c
|
|
@@ -40,7 +40,7 @@
|
|
#include <string.h>
|
|
#include <unistd.h>
|
|
|
|
-#ifdef SSL /*XXX*/
|
|
+#ifdef USE_SSL /*XXX*/
|
|
#define APOP
|
|
#endif
|
|
|