pkgsrc/lang/moscow_ml/patches/patch-ac
2013-10-28 23:49:17 +00:00

25 lines
765 B
Text

$NetBSD: patch-ac,v 1.7 2013/10/28 23:49:17 joerg Exp $
DESTDIR support.
--- runtime/Makefile.orig 2000-07-18 18:16:44.000000000 +0400
+++ runtime/Makefile 2008-04-27 22:38:26.000000000 +0400
@@ -1,6 +1,6 @@
# Makefile for the Moscow ML 2.00 version of the Caml Light runtime system
-OPTS=-fno-defer-pop -fomit-frame-pointer -DTHREADED
+OPTS=-fomit-frame-pointer -DTHREADED
BASECFLAGS= -Dunix -O2 $(OPTS)
BASELIBS=-lm
@@ -46,8 +46,8 @@ clean:
rm -f .debugobj/*.o
install:
- ${INSTALL_PROGRAM} camlrunm$(EXE) $(BINDIR)
- ${INSTALL_PROGRAM} *.h $(INCDIR)
+ ${INSTALL_PROGRAM} camlrunm$(EXE) $(DESTDIR)$(BINDIR)
+ ${INSTALL_DATA} *.h $(DESTDIR)$(INCDIR)
primitives : $(PRIMS)
sed -n -e '/\/\* ML \*\//s/.* \([a-zA-Z0-9_][a-zA-Z0-9_]*\) *(.*/\1/p' \