86 lines
2.7 KiB
Text
86 lines
2.7 KiB
Text
$NetBSD: patch-ej,v 1.1 2006/06/27 11:11:52 joerg Exp $
|
|
|
|
--- /dev/null 2006-06-26 17:53:40.000000000 +0000
|
|
+++ security/coreconf/DragonFly.mk
|
|
@@ -0,0 +1,81 @@
|
|
+#
|
|
+# ***** BEGIN LICENSE BLOCK *****
|
|
+# Version: MPL 1.1/GPL 2.0/LGPL 2.1
|
|
+#
|
|
+# The contents of this file are subject to the Mozilla Public License Version
|
|
+# 1.1 (the "License"); you may not use this file except in compliance with
|
|
+# the License. You may obtain a copy of the License at
|
|
+# http://www.mozilla.org/MPL/
|
|
+#
|
|
+# Software distributed under the License is distributed on an "AS IS" basis,
|
|
+# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
|
|
+# for the specific language governing rights and limitations under the
|
|
+# License.
|
|
+#
|
|
+# The Original Code is the Netscape security libraries.
|
|
+#
|
|
+# The Initial Developer of the Original Code is
|
|
+# Netscape Communications Corporation.
|
|
+# Portions created by the Initial Developer are Copyright (C) 1994-2000
|
|
+# the Initial Developer. All Rights Reserved.
|
|
+#
|
|
+# Contributor(s):
|
|
+#
|
|
+# Alternatively, the contents of this file may be used under the terms of
|
|
+# either the GNU General Public License Version 2 or later (the "GPL"), or
|
|
+# the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),
|
|
+# in which case the provisions of the GPL or the LGPL are applicable instead
|
|
+# of those above. If you wish to allow use of your version of this file only
|
|
+# under the terms of either the GPL or the LGPL, and not to allow others to
|
|
+# use your version of this file under the terms of the MPL, indicate your
|
|
+# decision by deleting the provisions above and replace them with the notice
|
|
+# and other provisions required by the GPL or the LGPL. If you do not delete
|
|
+# the provisions above, a recipient may use your version of this file under
|
|
+# the terms of any one of the MPL, the GPL or the LGPL.
|
|
+#
|
|
+# ***** END LICENSE BLOCK *****
|
|
+
|
|
+include $(CORE_DEPTH)/coreconf/UNIX.mk
|
|
+
|
|
+DEFAULT_COMPILER = gcc
|
|
+CC = gcc
|
|
+CCC = g++
|
|
+RANLIB = ranlib
|
|
+
|
|
+ifeq ($(OS_TEST),alpha)
|
|
+CPU_ARCH = alpha
|
|
+else
|
|
+CPU_ARCH = x86
|
|
+endif
|
|
+
|
|
+OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -DDRAGONFLY -DHAVE_STRERROR -DHAVE_BSD_FLOCK
|
|
+
|
|
+DSO_CFLAGS = -fPIC
|
|
+DSO_LDOPTS = -shared -Wl,-soname -Wl,$(notdir $@)
|
|
+
|
|
+#
|
|
+# The default implementation strategy for DragonFly is pthreads.
|
|
+#
|
|
+ifndef CLASSIC_NSPR
|
|
+USE_PTHREADS = 1
|
|
+DEFINES += -D_THREAD_SAFE -D_REENTRANT
|
|
+OS_LIBS += -pthread
|
|
+DSO_LDOPTS += -pthread
|
|
+endif
|
|
+
|
|
+ARCH = dragonfly
|
|
+
|
|
+MOZ_OBJFORMAT := elf
|
|
+
|
|
+DLL_SUFFIX = so
|
|
+
|
|
+MKSHLIB = $(CC) $(DSO_LDOPTS)
|
|
+ifdef MAPFILE
|
|
+ MKSHLIB += -Wl,--version-script,$(MAPFILE)
|
|
+endif
|
|
+PROCESS_MAP_FILE = grep -v ';-' $< | \
|
|
+ sed -e 's,;+,,' -e 's; DATA ;;' -e 's,;;,,' -e 's,;.*,;,' > $@
|
|
+
|
|
+G++INCLUDES = -I/usr/include/g++
|
|
+
|
|
+INCLUDES += -I/usr/X11R6/include
|