not found, but: Here is the summary of changes since 2.10.2: - Make fontconfig thread-safe - Use O_CLOEXEC to open a file - Fix/improve portability issues - new tool, fc-validate to check the glyph coverage against the language - Deprecation: - FcName(Un)RegisterObjectTypes() - FcName(Un)RegisterConstants() - FC_RASTERIZER - User-defined numerical expressions support in the matrix element - See conf.d/10-scale-bitmap-fonts.conf for example - Add new rule to scale the bitmap font and enabled by default - New objects support in FcPattern - FC_FONT_FEATURES - FC_PRGNAME - FC_HASH - FC_POSTSCRIPT_NAME - The cache version bumped to 4 - Support intermixed edit and test elements - Support delete and delete_all mode in edit element - Add --sysroot option to fc-cache - Fix the parser to ignore the leading whitespaces in the parameter - Auto migration for XDG Base Directory Specification - Match on FC_SCALABLE and FC_FONTFORMAT - Add quz.orth - Improve 30-metric-aliases.conf - Workaround the race condition issue on updating cache
21 lines
663 B
Text
21 lines
663 B
Text
$NetBSD: patch-ac,v 1.13 2013/10/17 07:27:33 wiz Exp $
|
|
|
|
--- conf.d/Makefile.in.orig 2013-10-11 04:28:47.000000000 +0000
|
|
+++ conf.d/Makefile.in
|
|
@@ -345,7 +345,7 @@ CONF_LINKS = \
|
|
|
|
EXTRA_DIST = $(template_DATA) $(DOC_SOURCES)
|
|
CLEANFILES = $(DOC_FILES)
|
|
-configdir = $(CONFIGDIR)
|
|
+configdir = $(prefix)/share/examples/fontconfig/conf.d
|
|
config_DATA = $(DOC_FILES)
|
|
templatedir = $(TEMPLATEDIR)
|
|
template_DATA = \
|
|
@@ -628,6 +628,7 @@ README: $(srcdir)/README.in
|
|
sed "s|\@TEMPLATEDIR\@|$(templatedir)|" $< > $@
|
|
|
|
install-data-hook:
|
|
+xinstall-data-hook:
|
|
mkdir -p $(DESTDIR)$(configdir)
|
|
@(echo cd $(DESTDIR)$(configdir); \
|
|
cd $(DESTDIR)$(configdir); \
|