pkgsrc/devel/glib2/patches/patch-cd
adam 5e53b3f935 Changes 2.32.2:
* GApplication: can now have a NULL application ID
* g_clear_object: fix warnings when using it on C++ (due to lack of
  ability to implicitly cast void*)
* GDBus:
 - add our own implementation of the message bus for use on Windows only
 - fix up a few bugs that use of this bus uncovered in GDBus
 - escape nonce files in dbus addressess (think 'c:\')
 - support initial underscores in dbus codegen namespace (for private)
* Fix misdetection of GNUstep as Cocoa (for the MacOS GSettings backend)
* make sure configure fails if AC_CHECK_ALIGNOF cannot detect the alignment
* GAppInfo: overwrite the DISPLAY only if it is set in the launch context
* glib/tests/date: force US locale running the GDateTime tests
* GSocketControlMessage: Don't warn about unknown messages
* Resources:
 - fix broken use of GVDB on big endian machines
 - set a 'display name' so that pretty file names appear in Gtk CSS
   warning messages
* GMainContext:
 - block child sources when blocking the parent
 - introduce more testcases for child sources
* Translations updates:
 Brazilian Portuguese
 French
 Galician
 Italian
 Lithuanian
 Polish
 Polish
 Serbian
 Simplified Chinese
 Spanish
* Bug fixed:
 619026 avoid warning in gutils.h when using gcc with -Wconversion
 669260 Open/Save dialog hangs waiting for data with libsoup
 671249 GApplication: Allow a null application_id?
 672786 goa-daemon: action in notification doesn't work
 673409 g_resource_lookup_data may return stale data pointer
 674172 glib-2.32.1 misdetects GNUstep as Cocoa
 674345 cssprovider: Make sure to print out file name in css warnings
 674483 broken configure results when cross-compiling with gcc >= 4.5
2012-05-01 18:45:51 +00:00

41 lines
1.4 KiB
Text

$NetBSD: patch-cd,v 1.7 2012/05/01 18:45:53 adam Exp $
sysutils/gio-fam builds the gio/fam backend as a separate module. Force it
to link against the installed version of glib2, as it is not rebuilt by the
package.
--- gio/fam/Makefile.in.orig 2012-03-11 23:56:05.000000000 +0000
+++ gio/fam/Makefile.in
@@ -87,10 +87,7 @@ am__uninstall_files_from_dir = { \
am__installdirs = "$(DESTDIR)$(giomoduledir)"
LTLIBRARIES = $(giomodule_LTLIBRARIES)
am__DEPENDENCIES_1 =
-libgiofam_la_DEPENDENCIES = $(top_builddir)/gio/libgio-2.0.la \
- $(top_builddir)/gobject/libgobject-2.0.la \
- $(top_builddir)/glib/libglib-2.0.la $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_1)
+libgiofam_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
am__objects_1 =
am_libgiofam_la_OBJECTS = libgiofam_la-fam-helper.lo \
libgiofam_la-fam-module.lo \
@@ -403,9 +400,7 @@ libgiofam_la_CFLAGS = \
libgiofam_la_LDFLAGS = $(module_flags)
libgiofam_la_LIBADD = \
- $(top_builddir)/gio/libgio-2.0.la \
- $(top_builddir)/gobject/libgobject-2.0.la \
- $(top_builddir)/glib/libglib-2.0.la \
+ $$(pkg-config --libs gio-2.0 gobject-2.0 glib-2.0) \
$(GLIB_LIBS) \
$(FAM_LIBS) \
$(NULL)
@@ -843,9 +838,6 @@ lcov-clean:
check-local: test-nonrecursive
install-data-hook:
- if $(RUN_QUERY_MODULES) && test -z "$(DESTDIR)" ; then \
- $(top_builddir)/gio/gio-querymodules$(EXEEXT) $(DESTDIR)$(GIO_MODULE_DIR) ; \
- fi
uninstall-local:
$(RM) $(DESTDIR)$(GIO_MODULE_DIR)/giomodule.cache